Bug in particle system - collisions randomly stop


we are running into following bug, which is best described by a video, so I made one:

What happens here is that we have a particle system, which is combined from two emitters. The second spawns a particle as soon as a particle from system one dies.

As you can see from the video, this works nicely in editor (in runtime simulation mode) and it also works in game. As soon as I press F11 (maximize view) the particles stop colliding. If I then press F11 again, it won’t collide anymore.

My problem though is that this is actually a random behavior, since sometimes they do collide in game and sometimes not. My example is just a deterministic way how to display this behavior always.

Is there any workaround or are we doing something wrong?

a lot!

Hi metamorphium,

I was unable to reproduce your issue. Could you narrow down a few things for me? Are you using two separate particle systems or one system with two emitters, I was a little confused by your wording. Also, how are you spawning the second effect, the assumed method is the use of the event generator inside the particle system (see screenshot).


Also, try to reproduce this in a blank project with only the assets needed and let me know how that goes.



Hi Ed,

thank you for taking time to look into my issue. Sadly it still doesn’t work. Here is my setting:



Please note, that it always works correctly in the editor, sometimes works in the game but always stops working when I press F11. Any idea what else should I check?

Alright, I’ve created a reproduction project using a default level, simple terrain and the particle system.

Steps to always reproduce faulty behavior:

  1. Download https://dl.dropboxusercontent.com/u/35645646/unreal/Test.zip
  2. Run the game in PIE - small window
  3. Press F11 to put it full screen
  4. Press F8 and move around a bit - particles stop colliding.

I also tried with 4.13.1, but the result is the same.

Hope this helps,