[BUG] Import Materials with Search Location: All Assets has stopped working in UE 4.17.1

After going from UE 4.16.1 to UE 4.17.1 a feature when importing called Import Materials with the setting Search Location All Assets no longer works. We’re reusing a lot of materials from another set of folders, and been utilizing this feature for import ease. This was working up until updating.

In 4.17.1: The Log shows that it does look in the same location as the file, as if Search Location was set to local. It can’t find the materials and therefore creates a new ones in the local directory.

I wanted to add that this bug is still present on 4.17.2…

We see this issue as well on 4.17.2.

Doesnt seem to work for me either. Using 4.18

Have experienced this problem too since version 4.17. The only option that works seems to be “Local”. "
I tried “4.19 Preview” and the bug is still there.

This still seems to be broken in 4.21. using all assets should find matching materials in the same project but does nothing. can anyone confirm this?

I can confirm “searching all folders in the same project” does not work with 4.20. The only option which ever worked with me is “current location”. Testing since version 4.13 someting like that…

I can also confirm, still not working on 4.21.1. Is there any workaround or planned fix?

I made a bug report. Unreal does not seem to care about the answer hub anymore.

The problem is fixed with UE4.23