[BUG?] FStringAssetReference do not resolve UObject

I have this kind of variable:

UPROPERTY(EditAnywhere, BlueprintReadOnly, Category = Sequence, meta=(AllowedClasses="LevelSequence"))
FStringAssetReference LevelSequence;

Before working with that I checking this is that not null

if (LevelSequence.IsValid())

This returns TRUE. After that I can’t resolve that variable! I tried all of this this:

LevelSequence = Cast<ULevelSequence>(LevelSequence.ResolveObject());
SequenceActor =  Cast<ALevelSequenceActor>(LevelSequence.ResolveObject());
UObject* obj = Cast<UObject>(LevelSequence.ResolveObject());

And all of this returns nullptr! What am I doing wrong? I checked LevelSequenceActor.h (he use FStringAssetReference too) and there is code the same and worked fine. Why it doesn’t work for me?

Figured by myself.
As API documentation for ResolveObject() says:

Attempts to find a currently loaded object that matches this object ID

Because my object was not loaded and not exist in level or memory, it returns null. In that case, I need just to load it manually with TryLoad() function