[BUG] Foliage distance culling incorrect in standalone game

No matter what values I set for foliage cull distance, the engine seems to cull nearly all the grass, with just a small circle of it left intact around the player. It works absolutely fine in the editor, in PIE or while simulating.

I’m using a FoliageType for a static mesh which I then drag onto the Foliage Paint tool. My quality settings are on Cinematic.

Here are the modified properties of my FoliageType:

Regards,
David

This happens in the cooked / packaged version as well.

Hello carpatican,

Can you provide a sample project that you can reproduce this in?

Thanks,

Lily

Hi Lily,

Please find it here: https://1drv.ms/u/s!Avvuj_oU4avll9cFJZhFM0NNxON_XA

Regards,

David

Were you able to verify the problem in the sample project I’ve provided? Let me know if you need anything from my end. We’re getting close to finishing the proof of concept of our game, and having foliage work properly would be fantastic.

Cheers,
David

ping? the repro project is till available here: https://1drv.ms/u/s!Avvuj_oU4avll9cFJZhFM0NNxON_XA

Hi David,

Apologies for the late response. I did some research on this and found something that may help. Could you try using a material containing the PerInstanceFadeAmount node? This might help with the Cull Distance in the Instance Settings once applied to the FoliageInstanceStaticMesh. Let me know if this helps at all.

Thanks,
Lily

Hi Lily, really appreciate your follow-up, thank you. I’ve tried using PerInstanceFadeAmount, not sure if I did it right but I got the same results. I’ve basically hooked the alpha of the base color up to the PerInstanceFadeAmount with a multiply, and connected the output to the opacity mask. Here’s a screen of how my material is looking like. Is this what you were suggesting I do?
Thanks, David

Hello David,

I’m trying to find the best way to go about this. I’m not sure if this thread would be of any help to you. https://answers.unrealengine.com/questions/16070/foliage-culling.html

Let me know if you need anything else.

Thanks,
Lily

Thanks to Lily K’s help I was finally able to get rid of the “bug” by first deleting my foliage mesh, foliage type and material, then recreating the above mentioned material graph from scratch.

I’ve also made sure to set sg.ViewDistanceQuality 4 via the console. sg.ViewDistanceQuality 3 was giving sub-par results. In the end, it might have just been a problem with my scalability settings, which as I’ve learned are different for standalone and packaged builds than they are for PIE and in-editor.

Therefore, this is not a bug, just my technical shortcomings when it comes to the packaging process.

Lily thanks again for your time, it was much appreciated!