[Bug, Feedback] How do I get rid of the Lightning Needs To Be Rebuild message?


Dear Friends at Epic,

This message is driving me up the wall

#I cant stand it

I am getting genuinely angry about my inability to have control over whether this message appears.


oh Please

tell me how I can get rid of this message!!!

#Dont tell me to rebuild lighting!!!

I know that!

I dont want to!

Tell me how to get this message to go away so I dont have to rebuild lighting or hear about it when I go to play the game!

Please do not tell me to rebuild lighting!

#Attempted Solution

The only quasi-related solution I found was this:

static TAutoConsoleVariable CVarPrecomputedVisibilityWarning(
	TEXT("If set to 1, a warning will be displayed when rendering a scene from a view point without precomputed visibility."),

But setting that var did not get rid of the onscreen red warning


Please incorporate such a functionality if it does not currently exist

I cannot stand the fact that I have no control over this message and I really DONT want to rebuild lighting!


PS you are witnessing me at the tail end of all my attempts to get rid of this blasted message, which has been irritating me since UE3 days.


Console Command-> DisableAllScreenMessages

Jacky told me :slight_smile:


omg you saved the day again. I’ve been wandering around in the editor for an hour to disable it. wow. thanks haha.

I had same problem. I fixed this with this blueprint (Below) but when I package the project the text was still there.
I restarted UE4 Editor and did a new Package and then it worked.


Thanks Budy…You saved my Time…:slight_smile:

hi is there a way of hiding only lighting messages not all? I need other screen messages?