[Bug] Editor freeze when testing dedicated server (4.15)

To reproduce:

Create a new Third Person template project (no C++ to save time)

In Editor Preferences, go to General/Miscellaneous section

Turn off “Use Less CPU when in Background”

In Editor Preferences, go to “Level Editor”/Play section

Set Number of players to 2

Check “Run Dedicated Server”

Uncheck “Use Single Process”

Set “Editor Multiplayer Mode” to “Play as Client”

Hit play

The dedicated server will spin up first. The moment the second client starts to load the editor will freeze up.
I debugged it and found that it’s waiting on an event that never comes.

Workaround 1: Don’t uncheck “Use Single Process”

Workaround 2: Don’t turn off “Use Less CPU when in Background”. You can turn it back on when the editor gets the game loaded.

I tried 4.14.1 and it happens there too. Perhaps this issue goes back further.

Hey Jin_VE-

Thank you for submitting a bug report. I have reproduced this issue and logged a report for it here Unreal Engine Issues and Bug Tracker (UE-43197) . You can track the report’s status as the issue is reviewed by our development staff. Please be aware that this issue may not be prioritized or fixed soon.