[BUG] Dedicated server connection issues with iOS devices (arm64)

Hi guys, we’re working in a multiplayer project for Android and iOS and we having an issue when we try to connect to the dedicated server.

Our dedicated server is running in a Windows Machine (Windows Server 2008 R2 Enterprise with service pack 1). If we package the client with armv7 our Android and iOS devices can connect without any problem, but if our package is arm64 it does not work on iOS devices (we not test arm64 in Android devices since is not a mandatory requirement for the Google play store). The arm64 architecture is now a Apple’s mandatory requirement to publish the app in the store (even test flight) so we need a solution as soon as possible. The logs we include next are from a developer build (both sides, client and dedicated server), but we already test in shipping with the same result.

This is the error log extracted from our iPhone 6 plus and IPad Air.

LogInit: Build: ++UE4+Release-4.14-CL-0
LogInit: Engine Version: 4.14.3-0+++UE4+Release-4.14
LogInit: Compatible Engine Version: 4.14.0-0+++UE4+Release-4.14

[2017.03.25-18.22.19:784][ 41]LogNet:Warning: Failed to init net driver ConnectURL: BSD: binding to port 0 failed (21)
[2017.03.25-18.22.19:784][ 41]LogNet:Warning: error initializing the network stack
[2017.03.25-18.22.19:785][ 41]LogNet: DestroyNamedNetDriver IpNetDriver_0 [PendingNetDriver]
[2017.03.25-18.22.19:786][ 41]LogExit: PendingNetDriver IpNetDriver_0 shut down
[2017.03.25-18.22.19:786][ 41]LogNet:Warning: Travel Failure: [PendingNetGameCreateFailure]: BSD: binding to port 0 failed (21)
[2017.03.25-18.22.19:786][ 41]LogNet: TravelFailure: PendingNetGameCreateFailure, Reason for Failure: ‘BSD: binding to port 0 failed (21)’
[2017.03.25-18.22.19:787][ 41]LogNet:Warning: Travel Failure: [ClientTravelFailure]:
[2017.03.25-18.22.19:787][ 41]LogNet: TravelFailure: ClientTravelFailure, Reason for Failure: ‘’
[2017.03.25-18.22.19:807][ 42]LogNet: Browse: /Game/Maps/MainMenu?closed
[2017.03.25-18.22.19:807][ 42]LogNet: Failed; returning to Entry
[2017.03.25-18.22.19:807][ 42]LogLoad: LoadMap: /Game/Maps/MainMenu?closed


  • UE4 - 4.14.3 (Source Version)
  • Compiled for iOS (using a iMAC)




iOS Config


(We’re also tried disabling the armv7 support in shipping and we got the same issue)

[link text][2]

[link text][3]

Other threads referring the same issue:

Hello DarielNS,

Thank you for reporting this issue. We’re currently looking into this but to keep information from being split up, can you please refer to the first post you linked ( iOS devices, ARM64 and dedicated server connection issues - Mobile - Epic Developer Community Forums ) for further assistance/updates? I’ll be posting there shortly with more information.

It worked perfectly!, Thank you very much for the help.