[BUG] Cascade, SubUV not working on mesh

Works fine in 4.9, 4.10 but when I enable " Scale UV" in the required component, nothing changes.

Uv’s are properly set up on the mesh.
Importing from 4.8/4.9 works, creating one in 4.10/4.11 is a nope.

Aaand… since im 4 hours into recording a particle/day and not being able to proceed due to this…
Is insanely frustrating.

Solved it.
apparently I didnt use the “Particle SubUV” texture node, which looks 99.9% identical to a regular texture node.
the regular texture node can be used for ANY AND ALL other sub-uv stuff, so why not for meshes?

Why are meshes relying on that specific node?
this is so odd.

Good fix. Thanks!

I just stumbled upon this and thank you Luos for that answer!
However, this solution works perfectly, but if you want to have flexible texture tiling, or a flowmap, the Particle SubUV texture node, somehow doesn’t give a sh!** and is unaffected by all UVManipulations. Just in case someone encounters the same issue:

My solution for this issue is to use a flipbook node. It works for particle meshes, you can manipulate the UVs however you want them to and you can drive the flipbook speed/animation phase simply with a dynamic parameter or the particle relative time.