BUG? Can not change r.Streaming.PoolSize in standalone game or final build

Hello there,

I always get the message “TEXTURE STREAMING POOL OVER xxx.xxx MiB BUDGET” in standalone mode or in final build. Regarding to a dozent of other threads and Epic documentation it should be possible to increase the poolsize by executing these commands in editor/game:

r.TextureStreaming 1 (enable texture streaming - not necessary if enabled in project settings)
r.Streaming.UseFixedPoolSize 1 (must be 1/True to change poolsize during runtime)
r.Streaming.PoolSize 3000 (Setting poolsize 3000 MiB)

Source: Texture Streaming Configuration in Unreal Engine | Unreal Engine 5.1 Documentation

We can execute these commands this way:

1 Run in editor, open cmd and execute them.

2 Execute these lines with an “Execute Console Command” node in level begin play for example.

3 Add these lines to DefaultEngine.ini and restart your project.

If we put the lines into DefaultEngine.ini, the lines would look like this:


I proved all 3 methods and they work! But they only work as long as i start the game in editor or in PIE. But none of them changes the pool size if i run the game (from editor) in standalone mode or if i build the final game and start it …

I remember a time when i had this poolsize problem 1 or 2 years ago and i definitly solved it by setting the streaming poolsize to 3000 (still part of my older code) and it solved the problom in the final build (still have an older build which works perfectly)

But now it seems, setting the poolsize has no affect at all if you start the game in standalone mode (from editor) or if you package your game to a final build and start it.

Can this be a bug or am i missing something? Would be great if someone could shed some light on this. It’s drivin me insane …

Thank you guys :slight_smile:

Did you ever get this figured out?