BUG 4.9 HUD DrawMaterial() unable to render translucent material

After upgrading from 4.8.3 to 4.9, HUD DrawMaterial() function can’t render translucent material.

Branch: 4.9 released

Build 4.9

Detailed description of the issue:
DrawMaterial() can’t render translucent material (after some testing additive seems to bugged as well).

Screenshots/Link to video:

Repro Steps: (I can reproduce this bug in clean project, below is my repro steps)

  1. create a third person template project.

  2. create a custom HUD class, assign it in game mode setting.

  3. in custom HUD class, create EventReceiveDrawHUD(), create DrawMaterial()

  4. create a translucent material, blendmode: translucent; shading model: unlit

  5. assign the newly created material to DrawMaterial()

System Specs:

Attachments:

I have this problem too. Funnily it does not show in mobile preview.

Hey guys,

Try setting the ‘Material Domain’ to ‘User Interface’ to see if that fixes the issue.

Let me know if you have questions or if this did not solve your problem.

Thank you,

Andrew Hurley

I’ve tried switching it to User Interface but the material still didn’t show up :frowning:

No problem, I will take the repro steps you have provided to see if I can get the issue to occur on my end. I will report back once I have completed my testing with any new information or troubleshooting suggestions.

Edit: To verify this is a C++ template project correct? As you description alludes to programming logic :slight_smile:

Thanks,

Andrew

I am also having this problem. I’ll have to defer my project’s upgrade to 4.9 until after this is fixed.

Confirmed here too. Changing material Domain yields the same result.

Yes, my project is a c++ template one. The repro test project is a third person template.

If you need more info please let me know.

Thank you for the quick response.

I have exactly the same problem.
Migrating the project from 4.8.3 to 4.9, all call to DrawMaterialSimple(), working before, do not draw anymore. In viewport, new viewport or Standalone game.

Hey guys,

I was able to confirm the issue in 4.9 as you are reporting. I have gone ahead and entered a bug report for this issue (UE-20792).

When a fix for this issue has been implemented it will be added to the release notes of an upcoming hotfix or full release. You can find the Release Notes on our Documentation or the Forums under the Announcements and Releases section.

Thank you,

Andrew Hurley

Same issue here. I’m gonna keep my project at 4.8 until this gets fixed.

Same problem here.

Andrew, I sent you a PM about the repro last week.
I trust you were sent the email and example UE4 project (from Stephanie) demonstrating the bug.

As mentioned below in my answer for this issue, I have entered a bug for this issue. This is a far as I can go until the developers get a fix implemented into an upcoming release or hotfix.

Thank you,

Andrew Hurley

UE9.1 realize and no hotfix for this critical bug.

Hi guys, this is now fixed and will be on 4.10. If you have access to github, fixed on changelist 2703083.

seriously why not include this in the hotfix?

major part of my UI is now unsable as the material are not drawn… so disappointed.

I’ll try to push it into a hotfix.

Thanks for the update.
I wanted to look at the change but Idon’t know how to fins a changelist #.
Could you please post the link?

Thanks,

https://github.com/EpicGames/UnrealEngine/commit/a707f055669966de1bf7bb3021bc173e89695bd8

Excellent news. Thanks.