[BUG 4.13] FBX importer Y to Z up

If you work in maya with Y up and have the FBX exporter set to Z up axis there are few issues working that way (outside of rigging). The updated FBX importer no longer sees the Z up conversion, as it did in all preveious versions of unreal.

  • Test Set Maya Y up
  • create a cube,
  • set it to be flat on the grid as if the grid is the ground. so a 10x10x10 cube would be set to y=5.
  • export as FBX Advanced Options > Axis Conversion > Up Axis = Z
  • Import into 4.13 place in level, its sideways
  • Import into 4.12 place in level its faces up

There are a few bugs in 4.13’s FBX importer, please revert to 4.12! This is the other Unreal Engine Issues and Bug Tracker (UE-37159)

This is super frustrating b/c everything imported right now (collision issues aside) is rotated 90. So when placed in level its getting unrotated 90, when this fix goes through any FBX updated will need all instances of it in game to again be unrotated. That on top of the collision issues is really frustrating, when it was all working fine in 4.12!

“transform vertex to absolute” import option needs to be on to import correctly

Hi Dave,

That will work, but I HIGHLY recommend working in Z up within Maya. It will save you a lot of headaches.

-Matt W.