[BUG] 4.11 AnimBlueprintCompiler Transform structure miss match causes editor crash

The problem started after yesterday’s commit SHA 0c5bc8be that added changes to AnimBlueprintCompiler.cpp in

void FAnimBlueprintCompiler::FEvaluationHandlerRecord::PatchFunctionNameAndCopyRecordsInto(UObject* TargetObject) const function.

so far what I found is that the editor will crash if you connect any input pin to the output pin of SplitStruct or Break of Transform variable.

What happens is as follows:

No crash:


In line #1865


The AnimNodeSinglePropertyHandler.SubStructPropertyName value is “Location” (the following image is taken after I found a workaround to the translation pin crash)

While SourceStructProperty->Struct contains “Translation” property and therefore the editor will crash on line 1866.

for this I found a simple workaround by just changing the name of the location output pin of the break transform function in the KisamatMathLibrary.

Now things are getting more interesting when it gets to the rotation pin, there is an element size miss match and the editor crashes on line 1867

Hey Lion032-

Could you explain where you are seeing this crash? I tried to break a transform node in an actor blueprint as well as an animation blueprint without crashing. Are you able to reproduce the crash in a new project? If so please detail the steps that cause the crash to occur. Additionally, if you are using the Master branch of GitHub (since you mentioned 4.11) you may want to try a more current version of the branch in case the issue has already been resolved.


The crash happens in the AnimBlueprintCompiler.cpp file at lines 1866, 1867.
Try breaking the transform in an animation blueprint in the AnimGraph.

I will pull the latest version in a couple of hours and I will let you know!

I created a transform variable in my AnimGraph and set it up to match your screenshot without crashing. Again, if you’re using the GitHub master branch (4.11) it is possible that changes that have gone in could have fixed this already. If that is the case you should be able to download the latest version.

Hi ,

I pulled the latest version and the bug is still present

Hey lion032-

How are you setting up your anim blueprint? Using the third person template project I tried creating a new anim blueprint with the default UE4 skeleton. Inside the animBlueprint’s graph I created a transform variable and split it with a “Break” node then wired it into the Transform (Modify) Bone node. If you are using a different method to setup your blueprint please list the steps taken that cause the crash for you. Also, could you post the callstack and log files from the crash to provide additional information?