BUG: 4.10+ Remote Build iOS for Distribution using Source

I’ve been at it for days and have combed through all of the other closely related issues. Here is what I’m running into while debugging.

I have a project set up with ONLY the valid distribution provision and distribution cert (I removed all developer ones). At the point in which it tries to use the iPhonePackager it bombs out failing all 3 (phase) checks. See the attached log.

The first phase it looks to validate if it is a debug provision (which it is not) and since the -distribution argument is not passed in it fails the phase check.

The 2nd and 3rd phase will only validate the name if it contains a * in the beginning which in my case it is not. My full provision bundle identifier is: P6U5######.com.ciinc.keepinitwheel.

So all checks fail when my project is set for distribution in the editor when attempting a package → iOS from my PC.

I haven’t even reached the part yet where it is supposed to work and there are issues trying to verify it =)

Based on the code it looks as though you HAVE to have both provisions and certs installed in order to get past the first issue. Once it can get past the first issue it seems to use the distribution provision/cert and complete. Of course there is the next issue which is taking the completed package and using the Mac ApplicationLoader 3.0+ to verify it.

When you do that you get this:

You can see the log of how it decided to package and build it [here][2].

I also read through all of the other issues and even tried using the iPhonePackager.exe that was just posted that is supposed to get rid of some bits to avoid this issue. None of that is working. I tried that AFTER I tried it with the latest .11 preview 7.

Just to be very clear I followed the new .exe from here: iTunes Connect invalid binary - Mobile - Unreal Engine Forums

But it did not work. I made sure to override it and manually sign it without going through the editor->package->iOS interface (as it will rebuild the .exe).

Let me know if I need to message you the IPA, provision & cert.

What is the ETA on this as we have been trying to get our app on the store for over 2 weeks. Is there a quick solution to do this on the mac (even if the mac cannot fully support the editor)??

Waiting to hear from you all. It has been a huge issue and is still not resolved. In the meantime I’m trying to install the engine on this slow mac and migrate our project over but will take a long time.

Jeff,

Thank you for being so patient while we investigate the error that you have been running in to. If you happen to resolve the issue by reinstalling the engine, please let us know.

We’ll contact you back as soon as we know more. Thanks! :slight_smile:

Is this a code-based project or a content-only project? Didn’t you have other issues at some point with just normal signing?

-Pete

You can just utilize UnrealFrontEnd instead of the full editor, but you will still need at least an install of the DotNet binaries and the Engine/Build directory.

  • Windows 10, gethub, latest code (v11p7).

  • Imported both developer & distribution provisions as well as certs as building “For Distribution” will fail if you ONLY have distribution provision/cert.

  • Selected For Distribution.

  • Built (via Rsync) and verified in log it was signed with distribution provision/cert.

  • Rsync used mac w/the latest OS AND Latest XCode updates (March 22nd)

  • Copied over ipa to Mac

  • Ran Application Loader against it.

  • Failed with screenshot above.

  • EDIT *

  • I can private message you with full Source/Provision/Certs/Content if it is a must.

Correct. But that went away with the preview 7.

Just so I am making sure I remember correctly. Didn’t you also have an issue with the stream read failure or was that another person? I’ll get one of our support people to PM you to get the signed IPA as a start. I can run some code sign validation here to see where it is failing.

-Pete

Jeff,

Could you please upload your IPA? Please provide it to me through the forums if you’d like it to stay private, I’ll provide it to Pete.

Thanks! :slight_smile:

FYI, the mac was just updated to XCode 7.3 (7D175) now.

So, I’ve been looking at the IPA and based on the validation checks, I think the problem is related to your original issue. When I added the fix for that, I was very careful to use anything that was read in. The stub in this case already has a requirements expression and so we just try to update it, but it looks like it is an old version of the requirements and so we should be updating it with the new signature. I’ll need to update some code and post a new IPP for you to try. I should have something tomorrow morning east coast time after I do some internal tests with the changes.

-Pete

Sounds good. Just to be clear, this isn’t a one-off build for me correct? There is an actual bug or do you think you are working with an IPA that was generated w/one-off code we worked with during the last issue? I’m asking because this IPA that I sent you was just created using the v11p7 code and nothing additional from our last issue that was addressed.

I think it is an actual bug. For some reason, there seems to be version 1 and version 2 of the code directory section running around in the wild. The problem is when we do the final signature, we need to make sure we are using version 2 of the requirements even if version 1 was loaded. I have fixed it so we always use version 2 of the requirements, but continue to use version 1 of the code directory if that is what was provided from stub. That passed the validation tests, so I have attached that IPP to this reply. Give it a try and see if you are able to upload. If so, let me know as I’ll need to get this change in to 4.11 which is going gold imminently.

-Pete
link text

It is rebuilding the shipping version now while I drive into work. I’ll be there in about 45 mins and let you know how it goes. Youngsville → Downtown Raleigh =)

It is uploading to the app store!!!

Is everything working properly for you now? :slight_smile:

Yes! He fixed a bug and it is working now. Did this fix make it into v11p8 or will I have to wait for v11 proper?