BT Services not activating

Hello all, my services in my BT have stopped working. Yesterday they worked fine, but after I loaded up the engine today all my services refused to activate. The services that stopped firing both took a reference from the owner actor, but I’m not sure if that is related.
Here is the BT in question:

Every other part of the BT functions perfectly except these services. I don’t know if it is settings-related or has to do with my engine version. I’m at a loss. Can anyone help?

I presume it’s the melee range service that isn’t working?

It appears that you’re using the Event Receive Activation to run the service, try changing it to Event Receive Search Start.

Each Event Receive type runs at different times, the first one to run is the Event Receive Search Start, which runs when the BT starts searching the branch, and is the only one which will always be called.

The next to run - but only under the condition that the branch returned a success, is the Event Receive Activation, so in your case, when your sequence is hitting the blackboard condition and probably failing, it’s not calling Event Receive Activation since it failed to activate, so the service is never being called.

Next to be called is Event Receive Tick, which will keep getting called until the branch exits with the final event, Event Receive Deactivation.

Hopefully this is your resolution, I had this issue once before where this fixed it.

1 Like

Thanks for the help, but changing how the service activates does not work. Its as if the services just don’t exist. Because the rest of the behavior tree works just fine, except for the services.

What happens if you put a breakpoint on the event being called in the service? Does the breakpoint trigger at all?