BT service does not get executed


I tried to mess with the BT Quickstart guide once I got it working. I tried to replace CloseEnough decorator with a serive but it seems it does not get executed. I tried to print a message from the service but it does not work.
Can you help me, please?

Your service is not getting ticked because none of the tasks in it’s subtree get activated. A service is only active as long as it sits on an active branch of the BT. Unless you enable Call Tick on Search Start flag in your service, then it will get ticked as part of “next behavior” search process.



1 Like

Thanks a lot Miezko!
Then how would I choose between two sub-trees? In the tutorial the decorator overrides the condition check but that is not what I want because if false my subtrees will not get executed at all, and when I tried to override receive tick in the decorator there is a problem with inheritance.

Should I post this as a different question?

It’s ok I had done something with abort, thank’s again!