BSP geometry wireframe flicker

Hey, I’ve got this problem that wireframe of BSP brushes flicker. It’s not something serious, but definitely annoying. Any idea how can I solve that problem?
If you wonder, my gpu is geforce 1070 (with latest drivers 382.05), so there shouldn’t be any problem.

Thanks in advance.

Hey FordonGreeman4,

Is there a specific time when it flickers? I need more context in order to be able to reproduce the issue on my end.

You can always convert your BSP’s into a static mesh once you have your final primitive shape, which should resolve the flickering.

Cheers,

Andrew H.

Hey, thanks for answer.
No, there is no specific time when it flickers. I just create BSP geometry, select it, and it flickers (even in new, clean scene). With static geometry this problem doesn’t occur.
However, it does not flicker on unlit and wireframe mode.

I can record short simple video of that probem if that would help.

Any way for me to visualize the issue is going to help in identifying and solving the problem.

Here you go

So I did some digging and found this is a known and reported issue.

UE-30764

It is currently backlogged at the moment, and a simple workaround is to disable Temporal AA while you work with the BSPs. You can use the Show > Anti-Aliasing dropdown in the main viewport to quickly disable/enable anti-aliasing.

Thank you,

Andrew Hurley

Thanks, no more flickering :slight_smile: