Download

Brush Max Size 8192.0 ?

With the sculpting tool we can create mountains or holes, but if you have a map of 2000x2000, how I can make the biggest brush?

Solved, size max is : 65536.0, But I don’t know if %render map or is Maximum

Instead of using the slider, just type in a bigger value. You can go as high as 65536.

EDIT: Just posted it a split second after your answer, never mind then :slight_smile:

Seems it’s been patched long ago. UE4.25, can only go as big as 8192. It’s tiny compared to my map. :’(

works fine on my end, you have to type it in. just type 70000 and it will max at 65536. 65536 is the max size in an unsigned 16bit integer.

1 Like

For anyone looking. 65535 is the limit of the brush size because the internals of the engine use a 16 bit unsigned integer to represent this brush size and 0 to 65535 is its limit.

1 Like

I see, I was setting it to 10,000 and it kept getting stuck at 8100 something, that’s whi I thought it doesn’t go above. I’ll try the 70,000 one

EDIT: OOOOOOOOOHHHH I’ve been using the brush setting all wrong! I always used to adjust the size using the “radius” in the upper toolbar, never thought about the brush size in brush setting. It works :slight_smile:

Weird though, that it works through one thing and not through the other. It’s like a little UE4 secret

It’s been like that (and reported as an issue that was completely ignored) since they up and moved the menus around.
About a year ago almost?
Don’t think they’ll change it at this point.

1 Like

Is there any reason it’s capped at 65k? Working on huge terrain and the max radius is still too small.

That’s the max size of the unsigned integer 16 bit that is in the code of the engine. Until they change it to uint32 which has a much bigger max value, we are limited.

Check out my USurfaceMesh plugin on the marketplace. It can now apply the mesh to the landscape. Maybe it might offer you some more features. I recently made it so you can capture part of the landscape, erode it and then apply it back onto the landscape. :smile:

Unfortunately, when trying to apply bigger brushes that affect many more vertices in the landscape, it just is going to take a long time to process that. Maybe that’s why they have a limit.