Broken VR Debug Draw in 4.16 Preview 1 & 2

Debug draw is broken in 4.16 Preview 1 & 2, any debug draw object (BoxCollision, SphereCollision) set to render will draw a second warped black lined outline only in the right eye in VR.

Reproduction steps: Place a collision component in the level and set HiddenInGame to false, play the level in VR.

I believe that was also an issue in a preview build of 4.13 or 4.14 that has re-emerged.

Hello mordentral,

Could you elaborate on what issue it is that you are experiencing and as to how it is at an inverse to what it is you would expect?

Any component that is rendered as a debug object has a skewed “shadow outline” of it visible in only the right eye when in VR mode as of 4.16.

I would expect this offset outline to not exist and also not be only in a single eye in VR.

Correction, they are visible in both eyes but with different offsets so they are not always visible in both.

Regardless the “shadow” copy should not exist to begin with.

I ran a few tests and I was unable to reproduce this issue on our end. Could you provide a small example project that shows the issue that you are having so that I could take a closer look?

Below is a fresh VRTemplate example from 4.16, the only change I made was to set “HiddenInGame” to false for the overlap spheres on the motion controllers.

To reproduce - open in vr preview with motion controllers and hold near face, observe extra black lines in vision.

https://drive.google.com/file/d/0B5cM3oP2O4-UeHZCdjJpaWtERWs/view?usp=sharing

I was able to reproduce this issue on our end. I have written up a report and I have submitted it to the developers for further consideration. I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Link: Unreal Engine Issues and Bug Tracker (UE-44947)

Make it a great day

I am also experiencing this bug in 4.16 release, just drawing normal debug lines. My current workaround is to disable “Instanced Stereo Rendering” as it only appears to glitch when that option is enabled. mordentral is right, a similar debug draw bug did appear in 4.13.

Yeah got the same thing here Aadarsh. Widget interaction debug lines experience the same issue.

Hi Rudy,

Can we get a followup on the issue? We have a release approaching, and I wanted to see if we can get an ETA for a fix?

Hello Cort.Soest,

You can use the link provided above for future updates. After taking a quick look it appears there is not an ETA as of yet on when this issue will be resolved.

Make it a great day

Hi this problem is still persisting in 4.17.1 Thanks

This is broken again in 4.171

After seeing multiple reports of this occurring in 4.17, it appears that there is some confusion with the public tracker. I double checked the link above and it appears that the current target fix for this issue is 4.18. I have provided a screen shot of the tracker as of (9/26/2017). I hope that this information helps clear things up.

4.17.2 issue not fixed, make sure that you tested in instanced stereo enable mode.

update: sorry for bump - confused by word Fixed (
may be better create new status - Fixed in 4.18 at once together )