broken static light baking in new gpu baking

I have a 2080TI, with up to date drivers and up to date windows. Everything enabled as mentioned in the 4.26 beta release forum thread.

static lights mostly not baking… In my level most of the static lights dont seem to bake at all. …Emissive areas do add to the bake however. Lights are seen when set to stationary or moveable but broken in static bake.

Other times in some areas … clicking one light and making it static stops it from working, but then selecting hte night next to it and switching it between stationary and static… some how makes the first light start baking again… problem is the last light selected and switched to static breaks and stops baking…

here are some screenshots of the issue. 1 half of the image is in moveable or stationary light the other half is the result from baking static with gpu.

2 possibilities:

  1. GPU Lightmass shares code with the path tracer, and we’re limited to 128 lights now
  2. Due to the same reason, non inversed square falloff lights are not supported
1 Like

This level has many sub levels. All with their own lighting. So question, if i have hit that limit, how do i get around it to light my scene?

Also i tried hiding all sublevels to only have one with 22 lights… still doesnt work… even resetting all of hte lights settings to default doesnt work.

Doesnt help that upgrading my project to unreal 4.26 switched all of my lights from lumens to unitless.

Also i think lights from the gpu do not go through back faces either. so u cant seem to hide em in a light bulb for instance… at least thats one of the working lights behavior.

even if i open up a sub level and delete all the lights so its less then 100… those lights are still broken…

Along with the already mentioned things… There is also an issue where pointlight intensity is tiny if the source radius is 0. Need to switch the source radius from default and anything above 0 should work for proper lighting intensity on gpu build.