broken shadows after building light

I am getting incorrect shadow after I build lighting.
the first picture is inside the mesh editor where everything looks ok. But in the main editor if I build light, then the shadows do not work properly. Any ideas about how to fix it?
All settings are default at this moment, I just imported the mesh as an obj in a default scene.

You shouldn’t have that all as one mesh

Part of the issue is that the lightmap resolution is too low.