Download

BP_Sky_Sphere Scene Too dark

I am not sure what I did with this one scene I am working on but for the life of me I cannot get this outdoor part to go back to what would be the default lighting and sky from something like you would see with a new default level.When I originally built this scene, I may have started with a blank level and therefore have no real idea how to get the outdoor environment to have a daylight appearance too it. I could import this level into a new project (I eventually will to clean up) but for now, it is on a GIT repository and I do not want to go through setting up a new repository. Any suggestions how to get this to a daylight scene?


Uncheck one or both of these (so 3 different tests in all):

Environment is Solid Color (Skylight details panel)
Atmosphere Fog / Sun Light (directional light details panel, “Light Source”)

If it doesn’t work, delete both lights and add in completely new ones. If it’s still dark, check World Settings, Project Settings, and Post Process Volume for anything that could be causing it.

Thanks for the response. I tried everything you mentioned to no avail. Crazy, crazy thing. I have spent hours trying to figure this out so I could learn something but the reality is I probably could have imported this into another project and just kept working.

One thing that makes no sense is I deleted the skylight and the directional light and the scene does not change. I mean the directional light shine bright on the objects int he scene but the environment itself is dark. It is not adding up. I even opened a fresh project so I could compare settings and I just cant find the difference.

I tried creating a new level and that to comes in pitch black.

So, since I am just so stuck on this, I created a new level/ map in the project using the Default Project Template that already has the skysphere blueprint, direct lighting and skylight in it properly. I then selected all meshes in the previous level/ map and copied and pasted into the new level/map. Well, now I have the skysphere and environment as it should be but for some reason the interior lights have blown out the scene to almost pure white. Nothing I do to the lights fixes this new problem. I turned them all off and did a new build and the same thing remains.

Well, I solved the problem without understanding why which is very frustrating. All of my lights I had set up in my interior on the level/ map that was not showing the skysphere lighting properly was working perfectly fine. Just the sky light was acting up. I then make a new level and that issue disappears only to now have the interior lighting totally blown out. I tried deleting/ turning lights off and doing new light builds but the blown out scene remained. I then reduce all of the intensity levels of the lights to super low and left them on with a new light build and that worked. Absolutely none of this makes sense. How is the light intensity good on one level but so drastically different on another level without changing settings after copying all assets to the new level? It just doesn’t add up but I need to get things done so I guess I’ll just move on without really understanding what happened.

Strange indeed. How about auto exposure? There could be overcompensation in the World Settings and/or Post Process Volume. Try enabling the auto exposure settings in the post process volume, and then lowering / changing those to reduce the lighting intensity and return the other lighting settings (the vastly reduced ones) to their previous levels. I was getting something similar in the material editor, where I simply opened it up and the preview was overblown with light. I turned off auto-exposure in the preview pane, and it fixed it. But I turned it off because there’s not the same options to adjust it as in the Post Process Volume. You might also need to check the Lightmass Importance Volume that is automatically added to a new level / project, particularly in the templates, and is referenced as Light Propagation Volume (so the two are the same thing being referenced by those names). Light Propagation Volume (LPV) settings are in the Post Process Volume details panel, and I think also in World Settings.

Hello Preston. I appreciate the response and helpful information. I am actually saving a copy of this thread in my “Unreal Learning” Folder where I save things like this for future issues. Frankly, the folder is getting quite large. Haha. Since I have the scene in good working condition at the moment and I am on timeline, I am moving on from this since I have lost almost an entire day trying to figure it all out. I did save a copy of the project file so I can possibly get back into that level and test some things like what you are suggesting. My issue is that as an architect and an enthusiast user of Unreal for ArchViz, I just do not know enough of the ins and outs of Unreal yet to be effective at trouble shooting something like this. I am grateful for the forums and users like you who try to help.

You’re welcome. I’m new to the engine, but have done a ton of reading and testing / trying different things in-engine to see what happens. I need to do a ton more to comprehend how different aspects are interacting and yielding results. ArchViz is primarily static and stationary built lighting, that is, if it’s not requiring dynamic lighting for certain purposes. I actually find dynamic lighting to be quite a bit more difficult than baked to understand so far. But baked is far more work-intensive, with the need to tweak seemingly every aspect of the lights and the 3D meshes to get it right. Unreal Engine seriously needs batch processing tools in the editor to make those tasks more efficient and workable. The devs are probably PO’ed at reading posts like mine from beginner to amateur users about their engine. But, if I don’t say something, wouldn’t it be misconstrued as things are moreso A-OK rather than addressing the issues? Sorry to sidetrack from your work. I’m signing off this thread now.