BP overlap events, only works on last placed BP

hi, i have a BP_elevator, it moves to the floor number you enter on the keyboard. it works nice. the problem is, when i place a second BP_elevator, then it only works the last placed and the first one doesnt trigger overlap events.

i made a little print string to verify this, and yes, when i step to the first elevator the overlap is false, and when i step to the last placed elevator it display true. if i delete the second elevator, the firstone start working well again.

im doing something wron for sure. but its odd because i have the same script set it on the level blueprint and the 2 elevators worked fine.

the image below is how i setup the overlap detection, i send it to a boolean variable so i can condition a key stroke.

Maybe I am misunderstanding, but I think you want EventActorBeginOverlap instead (???). I tried the blueprint (screenshot below) and it seemed to do what you are trying to accomplish. I placed several copies of this box on the level, and the box my actor was inside of did the following:

  1. Set the “ActorOverlapping” variable to my player actor.
  2. Set the “EstaAdentro” variable to true.

The other boxes (selecting them in the Scene Outliner, and looking at their Details) did not do this, and both of the two values above returned to null/false when I left each box.

If this answer solved your question, please check the green arrow to the left. Up Votes are always nice too :slight_smile:

let me try that. i some how fixed with a enable input and a disable input conected to my overlaping nodes. but, it suddenly stopped working later, didnt make any changes, just stopped working from nothing.

let me try what you are posting, and see if it fixes the thing. tnx.

Nope, i dont know what happend. everything was working fine.

i did what you suggested, but i have to ad the enable and disable inputs anyway in order to detect the overlaping, i dont know why.

the second image, is the thing that make the elevator go to floor 1, and stopped working just because. i will try to fix it today, hope you can suggest something about that.

I dont know what is happening, the BP triggers just fine, but the mesh does not move at all. i dont know what i did to broke it. :confused:

What does the function N01 do? It looks like that function is setting the target location for the elevator - is that correct? Is there something in there that maybe has a broken reference?

The function tells the lift where to go on the z axis, so it takes the current location and calculate where to move.

but i find out that the BP was not the problem, the BP worked just fine, the problem was with some components of the BP, i tried to set some triggerboxes to static, and that make the entire BP static. i fix that, but i still cant make some components static and have the moving lift at the same time.

im going to try to call a variable from other blueprint containing the trigger boxes. i dont know if thats correct but i will try it.

well that works, i have a fully functional elevator, but, the initial problem still remains, when i drag a second blueprint in the editor, the firstone stop capturing input, so nothing happens with keystrokes.

My simple “collisionbox” version using the blueprint below works as-expected (see screenshot below). I don’t think you need the check for “EstaAdentro” – you have already enabled/disabled input, so I don’t think that variable is needed to allow the player to interact with the elevator. I left it in, though, in case you are using it for something else.

Hi, i still having some issues with this.

the blue prints are working great, but only if i have just 1 elevator. if i put a second one in the world, things start to act wierd.

i´ll try to simplify the issue:

i have a BP with a collision box, on overlap it sets a boolean variable “X” to true. and i have other BP with a print string the value of “X”.

if i set just 1 BP with the collision box, and i print the value, it works fine. but if i place a second blueprint, only the second one displays the correct value of X, the firstone alwas display False, even if i´m overlaping.

hope someone can tell me what is happening.

Its been a while since you last said you were having problems with this, but i stumbled across this one just recently.

I was able to fix this issue, by using ‘Enable Input’ as part of the ‘Begin Overlap’ event.

Here’s a screen shot of my setup. Hopefully it works for you.

Probably a bit late for a reply. I haven’t seen your complete blueprint but I think I can hazard a guess why only the last placed blueprint is working with the trigger.

You may have a variable/conditional statement “is overlapped” where one of the outputs is blocking the flow for the second instance.

I’m not 100% sure if this will solve your problem but might be worth investigating.

Essentially for your input event remove the setting “Consume Input”.