Box/Sphere trace not detetcing landscape

UE4 Version: 4.14.3


I have a landscape in my level that has ‘generate overlap events’ enabled with these settings:

I have an actor with a ‘multi sphere trace for objects’ with the appropriate object types set up:

The trace will correctly pick up everything else that it is set to, apart from the landscape. I have tried opening a fresh project, adding a landscape and having an actor with physics enabled and a sphere trace (even tried a box trace) on tick move around the map.

Neither of these methods provided any results. I have also tried it in 4.13.2.

If I have a collision sphere on the actor, that easily detects any overlaps with the landscape, so I am led to believe it is something to do with the traces.

Perhaps this is a bug, or perhaps I am missing something. Any help would be appreciated.

the collision settings is set to ignore the traces “selectableHo…” and “selectableMo” if you want it to generate overlap events you should set it to overlap, are you sure your trace isn’t a “selectble(ho…/mo…)”?

I tried turning every option to overlap and it didn’t change the result.

As I stated in my post, I have tried a fresh project with no extra collision channels like my project has. Still no results. I just tried it in 14.15 and the sphere trace will still not detect a landscape.

for some reason sphere traces don’t work on landscapes if they have the same start and end location. I have no clue why, sphere traces with the same start and end locations work with anything else (I’m still on version 4.15 tho)


Well that worked!
Thanks man.

You just saved me hours of debugging. Thanks!

Whoa! Thank you so much for this!

muchas gracias, me ahorraste mucho tiempo y dudas.