Bots/Actors can't trace Player Mesh by default

Today I tried to find out why the tracelines of my bots dont get my player as hit object. As you can see in my blueprint the hit object responded just an empty line even when the little red line hits my character.

This problem is caused by the default collision settings of a ThirdPersonCharacter.

The Mesh > Collision Response > Visibility “ignores” by Character Mesh default.

If this particular setting gets set to block, bot to player tracing works fine.

I think this “default” has to be

For replication: just set up an actor an let him trace your ThirdPersonCharater and print that “hit object”.
In Theorie you should get a string ThirdPersonCharacter, because of that settings, you get an empty line.

Let me know what you think about that.
Anyway, Thank you for this great engine <3

Hello te4zer,

If you would like to get the character when doing a line trace by channel you could do so by setting the trace channel to camera. I hope that this helps.

Make it a great day

no, not really, he bot character tracks himself then even with ignore self on!

I tried to reproduce the ignore self not working issue and I was unable to do so. I have provided a picture of the example I am using.


These are the nodes that I am using to do a line trace for the player character. This setup ignores the “BotCharacter” that I have while providing a hit on the player character.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list a steps to reproduce this issue on our end?
  3. Could you provide updated screen shots of any blueprints that may be involved with this issue?

As you advised, use camera mode, does not work!
the onyl fix that works is that collision visibility change!

I am happy to hear that you have it working. However, could you provide answers to the questions from the post above? This will help narrow things down a bit further.

The point is, that in my opinion the “default collision of CharacterMesh preset” in the explained case should be set to “Visibility > block”

We will take your concerns into consideration, thank you for your time and information.

Make it a great day