Download

Bones offset when importing fbx made with Blender

Been following these three tutorials:

Which have been really helpful.

So here I am, modeling and rigging my low poly character in Blender. I’ve tried different skeletons but always using the UE mannequin naming convention.

However, when I import the fbx-file, my bones behave as if they’re dragged towards the spine and down to the floor.

As show in the image, for example, my thigh (both left and right) has in UE moved “up” along with the rest of the leg, resulting in the foot bone being where “calf_l” should be placed. My hands have been moved to where the underarm should be and the head to where the neck should be. All the bones are there, they’re just not where I want them and I can’t understand why not.

I’ve probably missed something important but I’ve tested two different models, with different bone adjustments, namings and settings and all of them end up in this way. Why? Could someone please point me in the right direction. This is infuriating.

Also, this physics-asset-thing, should it look like this after an import? According to Pontypants tutorial, it would differ if my scales are wrong but I seem to get the same result anyhow, with only 2 cylinders.
UE_physics

Any help would be greatly appreciated! Thanks :slight_smile:

(Unsure about category. Picked “Animation” since that’s what I want to use my characters with)

EDIT:
This is probably the same problem:

Using:
Unreal version 4.26.2
Blender version 2.93.2

i just check in the tuto how he export, did u try uncheck “Only Deform bone” during export, might give it a try.

Else sometime there a glitch in blender on cache when exporting to ue4. Try File>Clean Up everything, that solve my problem on having weird skeletal mesh in ue4.

You can upload your file here to see if we can help.

Yes, I’ve done with and without “Only Deform bone”.

Cleaned all as you suggested but sadly it didn’t help.

Here’s the file:
LowPoly1.blend (1.1 MB)
LowPoly1.blend1 (1.1 MB)

Thanks for trying though!

It doesnt lean left for mine:

In blender i deleted everything except root and Hat. Exported with:

In ue4, default import setting.

It looks like when I import it from your image. The foot-bone is now it’s calf and I would assume that the thigh have also been moved. Also the Pelvis bone is touching the ground, is it not? The head probably does not have a bone either, it has been moved down to it’s neck.

hmm ye something odd that i cant figure out too.
well i recommend to go for traditional way, this is what i have started with:

i always make my characters from scratch bones and rig, it just save me time else i spent hrs/days troubleshooting meta-rig human or other youtube tuto.

Cheers dude. I looked at that video and another then I used the skeleton from rigify (MetaRig). However, nothing change. My pelvis bone drops to the floor and drag everything with it. The ball move to where the foot-bone should be, the foot-bone to where the calf should be etc.

Look at this:

I don’t understand :frowning: I even tried to rename the whole metaRig to how Unreal name their bones but the same result. Always the same issue.

i thk it totally fine, i have that weird pointing down too on my models.
And look the same in your tuto like the head bone is smaller in ue4.
Just test by adding some animation to it and see how it look in ue4.

So I retargeted etc the animation and got the running one from the Mannequin working somewhat.

The characters left side doesn’t… act weird like how the right foot and hand mesh just shows up in a faulty way. However, the legs are super broken. As if they lack bones or as if the weird bone movement after import effects the mesh.

How can this be so freaking difficult? I don’t get it. I also don’t know what terminology I should use when searching so that’s not going well either.

well u should manually edit each part weight(vertex weight).
Just follow the youtube link i previously sent, and start from scratch, dont use the meta-rig human.
Everything should go smooth if u follow blender official youtube guide.

Yeah, that’s my though but it doesn’t. Hence why I am frustrated.

You don’t happen to have a Blender model that works to import to UE that I could look at and compare? One where the bones doesn’t move around to other places, I mean.

sure, i will send it via personal msg.

1 Like

The bone representation in ue4 is useless. Forget it exists.

The foot bone seems to not be importing from the graphic, but again it doesn’t matter. Look at the bone hierarchy and see if a bone with the name you gave the foot exists.
Select it, and make sure a controller of some type exists within person allowing you to move and rotate.
Assuming it does the bone is fine.

If it doesn’t, you didn’t export correct. Or import incorrectly.

In Blender, before you export the main skeleton or any animation, you need to select the armature and apply all transforms.
Not doing so often results in the twist behavior of one of your images.

As far as models go, export the mannequin.

Delete the mesh.

Adjust the individual bone positions to your current armature’s joint positions. (Don’t delete bones - if you don’t have a bone because yours is low poly place it on top of another bone you already placed.)

Parent the armature to your mesh with no weight.

Go into the mesh details and start renaming the vertex groups from your old armature names to the names of the ue4 bones. (Making sure that posing the ue4 bones causes the vertex to move).

Save it.

Delete your armature.

Export (could also do selected objects, selecting armature and mesh, but deleting is safer).

Import to ue4.

Test a ue4 animation via retargeting.

Hey! I hope you have already figured out this issue, if not here is fast short vid I made for you.

I myself learn rigging and working with UE for less than a week, so maybe I’m not doing everything right, but it somehow works.

Right now I don’t know how to export multiple meshes ( a hat is separate from body), so I combined them.

Video: Rig vid - YouTube

P.S. I also have an issue with strange incorrect bone orientation (Incorrect bone orientation only in run animation)
Hope someone could help me with it.

1 Like

Looks to me like you are just interpreting when you are seeing wrong. It is somewhat funky in UE, compared to Blender, at least visually. It’s just putting the name of the bone where the bone starts, and not showing the last bone’s length, as what you consider to the the bones, is just the beginning of 1 bones, extending to the next bone in the chain. If there isn’t another bone in the chain, then you won’t see what you consider to be a bone. The bone is there though, it is just that UE considers the bone to be the start point of the bone, and not the length that extents to the next bone. Technically, the last bone in a chain can be any length, and it won’t matter.

That clip was great, Elder_Mask. Not really sure what you did differently than what I did except for the scale change but when I followed your instructions everything looked fine and worked. The Physics even have more cylinders now :slight_smile:

And I do think the bone presentation difference between UE and Blender threw me off which in turn lead to me trying to fix something that was already working. Good thing I’m not the first one into the world of UExBlender and that you guys are so helpful. Thanks!

EDIT:
Also, @Elder_Mask apparently I can’t save your clip to my playlist because that function is inactive for clips aimed at kids. Not sure if youtube did that themself or if that was on purpose :stuck_out_tongue:

1 Like

I’m glad that clip was helpful!
Scale is a prerequisite for UExBlender workflow.
It seems like the scale doesn’t need to be changed if using the official “Send to Unreal” plugin, but I’m not using it yet.
Also, Idk why this “kids” functions was on, so I disabled it. Now you can save it :slight_smile: