Blurring ssr

Is there any way to blur ssr, i want blurry ssr without using an insane raycount or a ton of grain, Solution?

SSR will be blurred based on roughness if it’s on quality 3 or 4. You can tweak the steps and samples for each quality level in the .usf if needed.

SSR in UE4 has temporal interpolation implementation, which is supposed to be enabled by default according to the command help but is wrongly set to 0 for all new projects. Once you set it to 1, you should observe a drastic reduction in noise and improvement in the quality of SSR.

This comes directly from the following post:…ce-reflections

you can downsample SSR to half res with a cvar which effectively will blur it slightly

another option is to make a postprocess material setting the Blendable Location to SSR, take the scenetexture and blur it yourself with nodes using several uv offsets and averaging them. it’s basically like a blur postprocess material that will only affect SSR. won’t be the cheapest thing but it’s the most effective way to blur the SSR

mind that once you use an SSR material postprocess, the downsampled SSR cvar will not have any effect (they are mutually exclusive)