Download

Blurring Shadow Problem with Contact Shadow Settings?

Hi, I’m currently working on transfer a large scale architectural project into UE5,

with 4~5 low-rise building imported, the rendering resolution still looks nice,
but after I imported a few large towers, my editor accidently shut down,
next time I restart the project, the rendering preview went all fuzzy,

after few tweaks of settings, found out it was the shadows issue,
I could still get the proper outcome if I turned off Contact Shadow Lengths feature and set the value to 0, but it will lose the realistic indirect shadow effect.

How can I fix this problem without compromising the shadows quality?

Thanks.

try using virtual shadow maps or raytraced (if hw permits)

1 Like

Hi, I’ve tried to enable the hardware ray tracing feature and rebuild the map,

it took some time to do that but the fuzzy shadow still exists…

though buildings in the whole scene looks a lot sharper and the FPS got smoother too,

this method anyhow did help me improving the realistic scene, thanks :]

Dont use contact shadows, they rarely work. They sometimes work at 0.05 length, but everything else is unusable. If you want the best dynamic shadow quality, adjust your shadow exponent/distance, and experiment with far shadows if you need those. And if you want the best quality and have hardware RT on your card (GTX 1060 and above), disable contact shadows.

1 Like

Hi, Thanks for your suggestion,

I’ve reimported the model and set RT & contact length to 0.05
and totally satisfying with this outcome now.

but will keep trying the exponent distance later when I’m available.

Thanks for your kindly help :]