Download

[Blueprints] Prototype Menu System

Thanks, I’m getting it now. My knowledge about setting sound systems is almost non existent. So it’s good to see that you got sound options covered. :smiley:

Bonjour,

Excellent travail !!!
Merci pour ce partage.
C’est exactement ce que je recherchais.

Best Regards

After a long hiatus, I’ve started working on the Prototype Menu System again. The project has been updated with a lot of improvements to the existing codebase and now supports the latest v4.19 edition of Unreal Engine. It’s still work-in-progress with the audio/gameplay settings still not ready, but you can still get the project in its current state from GitHub: **[https://github.com/RohitKotiveetil/U...typeMenuSystem

graphicsoptions.jpg](https://github.com/RohitKotiveetil/UnrealEngine--PrototypeMenuSystem)**

For more details about the current feature set, check out: https://unrealpossibilities.blogspot…prototype.html

So i downloaded this project and its realy amazing how its made. But when i migrate it to my own project i just get a black screen wehn i hit play. The game-mode is the same, all settings are the same, i didnt toutch any blue prints but nothing is showing. Please help :confused:

Hi, I didn’t get a notification for this post for some reason. This is really late for a reply, but just in case you haven’t found out a way to get it working, I’d suggest setting your game instance to BP_GameInstance from the project. There’s a pretty good chance that your project might be using the engine’s native game instance class.

v2.1 edition now live on GitHub.

Change Log:

  1. Added a new ‘Gameplay Options’ menu with the following customizable settings:
  • Mouse X Sensitivity
  • Mouse Y Sensitivity
  • Invert Mouse Y Axis

21.jpg

  1. Game settings modifications now handled through the ‘BP_GameInstance’ blueprint.

Hi first of all thanks !
That’s abolutely great and what i’m looking for.
Before ask my question, …have to tell that i followed your tutorials on youtube, but as a total newbie this gave me an headache :slight_smile:
So first , once migrated to my project i got a black screen, i read… and change to Game Mode to BP_GameInstance, now it load fine, but when i click START, i got errors, which seems like chinese for me at this time (see screenshot )
Can you help me to solve this issue please?
Best regards
Erick

Hi Erick, do you have any maps set for Editor Startup Map & Game Default Map options under the Maps & Modes section of your Project Settings?

hi Thanks for ur fast answer…
Yep i have special map …The 'map_MainMenu" :slight_smile:
But think it’s relative path problem// I wanna load a Map called ODYSSEA3 wich is at root folder …But i don"t know where to change the path URL in your Blueprint.

BTW, i managed to make it works moving my “ODYSSEA3” map tfrom Root to “Prototoype MenuSystem” folder and rename it 'MApSimple LEvel" but seems there’s a conflict, i cannot move my SinglePlayer anymore in viewport.

So sorry i’m sure it’s stupid question.
Thanks.

Alright, so if it’s working when relative path remains the same, then the issue might be associated with loading the map in blueprint. Just open up the BP_GameInstance blueprint, and set your map names in MapNameArray. The first index corresponds to main menu map and the second one to a gameplay map. Try replacing the second element with your ODYSSEA map.

The tutorial instructions you referred to earlier were probably from a version released a couple of years ago. The project has undergone some changes since then. So just make sure that you’re using the BP_HUD_MainMenu & BP_HUD_InGame blueprints as your default HUD classes as well.

Big Thanks that was why i’m looking for…! got some errors but working… :wink:

Happy to help :slight_smile:

:)…working on editor…
but when i package project for windows 64 …and push “START GAME”…it stay on Main_Menu… Other thing to change?
Thanks.

I’m not sure about this one. Could you try right clicking on the root folder in content browser and select the Fix Redirectors option?

No change…:frowning:

Does it say the same when if you use the default sample map as the second level?

Thanks…i didn’t want to push as my questions are certainly too stupid …and didn’t waste to loose your time.
I just made a 1 mn video , think it’s gonna be more easy to see what i’m doing wrong :slight_smile:
Sorry…
https://www.youtube.com/watch?v=Xz64…ature=youtu.be

Hey, don’t worry about it. All your default settings are fine based on what was shown in the video. So the issue might be associated with the transition to new map itself. Try overriding the game mode for your custom map to BP_GameMode_InGame. Alternatively, you can use your own game mode but have its default HUD class to BP_HUD_InGame. Either one of these changes should ideally make it work as expected.

Nope same result …If it’s not abused, can u try same setup as mine? or call a map at root level ?

Yea I did try that approach. Two things worked for me. The solution mentioned in the last post and removing the “Update Game State to loading screen” node just before the open level node in BP_GameInstance. You can try out the second approach. It will remove the loading screen, but it might get the job done.