Blueprints "Overlapping"?

Hey guys,

I made a few blueprints for some cabinets that I wanted to open each individual drawer of, and they worked perfect. So I moved on to another type of cabinet, almost identical blueprint, but instead of making a 30 unit Y Axis transition, I set to a -118 unit X Axis, seeing as it was a sliding door on a different cabinet. But the Y Axis from the first one seems to overlap into the second, and on other occasions the -118 Unit X Axis over laps the first, so one time the sliding door will just come straight out towards the player, and other times the cabinet drawers will go through the side of the cabinet body.

So I decided to walk away from that for a few minutes and turn to a locked key and door blueprint. The door was similar strings of blueprinting, using rotators instead of vectors, and the key was different, naturally. But when I went to test them, I placed the key on the “Broken” Cabinet (The first of the two that overlap) and when I tried to interact with the key, it started moving 30 units along the Y Axis, and other times I just can’t interact with the key at all.

If anyone has had similar experiences, or would have any ideas that would be great! The first three pictures are of the 30 Unit cabinet, the fourth is the -118 Unit cabinet, everything off screen is identical to the first set. And the last picture is of the key.

Am I overusing the Event Begin play too much? Or do I have too much bound to the Interact key? Everything works perfect when they are by themselves, the cabinet drawers are perfect, the sliding door is perfect, and the key can be picked up and works on the locked door.

Thanks in advance!

Small side question, is there any way to tighten up the line trace? I want it to be right in the center of the screen, but it seems to be a large area it covers.

I can tell you your line trace code is wrong, that’s why it’s not working :wink:

You’re supposed to add the two vectors together to get the end point.

Can you show me the component structure of one of these drawers that’s not moving properly? I will show you the easy way to code it.

( I need to see the pivot ( widget ) of the drawer component ).

Thank you for pointing that out! I dont know why i forgot the addition in the one for the key.

The other screenshots have the addition for the end point in it, but i must have missed it there. The first three is a full line of code (231703, 231730, and 231743) for the first cabinet. 232409 is a clip from the second cabinet, with everything off screen being identical to the first.

Screenshot 074416 is the component structure for the first, and 074439 is the second.

Let me know what you think!

One other little thing I had a question about.

I built the cabinet with the line trace, and like I said, it worked perfect. But before I did the line trace for the key, I had it all set up for a hit box, as well as the door. But for some reason, if I hit my interact key and caught it anywhere on the hitbox for the key, it would cut all interactions, which is why i went to the line trace for the door and key. Now I’m stuck with this weird overlap issue and a door that i can’t seem to make work.

But any idea on the interaction/collision box issue? I attached the original key blueprint for a reference

I’m getting lost now. I thought you were having a problem with the drawers moving the wrong way, which I think it an issue with how you have your pivot point positioned.

EDIT: In any event, line trace with blueprint interface is the best method. With the overlap method, you can still operate the object while facing the opposite direction :slight_smile:

I completely agree with like line tracing, sorry for the confusion.

Everything is perfect alone, but together its almost like one action gets set for all of them, not their individual.

What does that do? I’ll check when I can get on, but I haven’t made any changes to whatever the default is. Do I want it checked?

Did you uncheck this?


It’s your problem. The default is, only one BP will work at once… :wink:

I still think that’s what it is. Do you have any other interactables in the map?

Can you try the two objects in an empty level?

Otherwise, it’s a little hard to diagnose from here. If you could put them both in an empty project and zip it up so I can download it from somewhere, I’ll take a look… ( tomorrow )

So i got on, unchecked consume input on both, and still had the same issues… Any other ideas?

I tried and empty level, just one floor, directional light and skysphere, still the same thing. If you wouldnt mind looking i would really appreciate it!

Ok, so make a new empty first person project. Then, from your current project just migrate the assets ( the two objects that don’t work ) to the new project.

Check nothing’s missing in the new project, then File → Package → Zip up project, and put that on google docs or we transfer etc.

I will take a look…

Ok, cool - just drop the link in here :slight_smile:

I set up a we transfer, how do i send it to you?

Ok, getting it now. It might be tomorrow before I take a look…

Ok, I see the problem, but it’s gonna take a while to explain.

It’s easier to get it working without the line trace first, are you ok with that?

EDIT: Actually, hmmm. If you want to be able to open drawers separately, you have to use line trace.

If you use an overlap volume, you can only open one drawer per object…

Thanks a bunch for looking at it! I was trying to put the line trace on the character blueprint, so if you see that on there i was just trying different avenues

Thats perfectly alright! Whenever you can get to it

Yes of course