Blueprint Variables Animated Doesn't work in the Render Queue

Hello! I animated some blueprint values in a sequencer, that changes some texture parameter and some lights as well. It works perfectly in the sequencer playback, but in the Render Queue it doesn’t animate. It takes a state and keeps it static. Everything else is moving correctly. So how can I make the Queue affect blueprint variables?

This is the secquencer look:

This is the rendered queue look:

The standing light structure is a blueprint with some variables animated, and none of it works. it includes texture animation, a spot light aniamtion, and some tilt motion too. So the issue has to be queue and blueprint communication.

Can you guys help me out? Thank you!

I further analyzed the problem and it seels like the issue is the construction script freeze. If I click on the end frame of my animation and render it like that, the light will be on from the beggining in the queue render.

So the issue seems to be the queue doesnt recalculate the construction scripts of blueprint actors, although in the blueprint settings i have the settings turned on:


Now that I knew how to search for the issue, i found a discussion thread on it, and it solved my issue giving me the answer that Queue can’t rebuild construction scripts. I solved my problem like these people: moving everything to an event tick.

This topic has been moved from International to Rendering.

When posting, please review the categories to ensure your topic is posted in the most relevant space. Hopefully, this category change will help other devs to find an answer.

Good luck and happy developing! :slight_smile: