Blueprint Services doesn't get executed

I am trying to create a checking mechanism to check whether my controlled main character is alive before executing the chasing mechanism. But when I try to run it, it seems the blueprint services didn’t get executed. I tried to use both event reactivation and event reactivation AI in case I made the wrong choice (still not sure the differences are) but seems like both didn’t get executed. Can anyone help me point out where the issue is?

This is my behavior tree

This is my service that check whether my mc is alive or not

For permanently checking the player - what about using the Event Receive Tick

Here, you can set the interval to run this check.

I tried to change it to event receive tick AI and connect it to a print but it still doesn’t get executed. any idea why?


Does checking Call Tick on Search Start in the Service details change anything? I do not have it checked in my working BT, but might be worth to try.

Yes it does work. Although now I am confused why it needs to be ticked on mine but not yours.

Also for some reason it always fail to do casting. Any idea on this?

If the default interval is still set, at 0.5 +/- 0.1, you may not end up in that branch on the tree long enough for the tick interval to hit