Blueprint "Print String" not outputting to screen

I don’t know what I did, it’s just not showing up on the screen. But it’s showing on the output log.

It was working a few minutes ago, I didn’t change the HUD class or anything… I’m completely puzzled.

Howdy!

By chance do you ever destroy the BasePawn actor which holds this Event Tick?

-W

Nope.

I added Print String to other blueprints as well (even Tick on the level blueprint) – it’s never printing on screen.

Can you post a full image of your Blueprint so that we can take a look at what’s going on?

Hmm, it’s working now. I’m not sure what solved it.

I did attempt to restart the editor before and that didn’t solve the problem. So I tried to change the build config to Development Editor and it worked. Then I went back to DebugGame Editor and it’s working now too. :o

Thanks for your time though.

Ever since 4.6 I’m exeriencing that issue too… it just comes and goes as it pleases… usualy restarting the editor solves it… (though sometimes It needs 2 or 3 restarts in a row to work…)
Currently in 4.7.5 (where that bug became way more recurrent)

I haven’t been able to reproduce this on my end. Do you have any specific information that would assist me in recreating this bug?

Hi! actually… it’s a pretty random bug. it happens on my personal computer as well as in many of the machines in the school I teach, and it happens randomly amongst my projects…

Usually restarting the editor solves it, but sometimes just by changing my system’s language/keyboard language settings and leaving my PC Idle for some time also solves it… (My keyboard is currently somewhat broken, I’ve considered if my keyboard isn’t auto-pressing some random keys that could toggle that behaviour on/off… but the same bug happens on many of the machines in the school, so… no Luck there…

Does this only occur when your keyboard is in a language other than English? What other language is your keyboard in? Have you adjusted the editor’s localization settings?

Hi. actually that only happens when my keyboard is set to English - US (the keyboard config with the tilde right bellow esc key). My other languaes are Portuguese - ABNT and Japanese with 3 setups. but the issue only happens while I’m in english.

I’ve tried to reproduce that bug by shutting and restarting the editor with other languages set in, and also tried changing the localization, but since it’s a pretty rare/random bug, I couldnt reprduce it enought to get any conclusions…

My localization settings is set to enlish, un-specified region. But at the school some are in portuguese and others in english…

Is it the same at the school? Do the Portuguese setups produce the error or is it still limited to the English PCs? I’m still unable to reproduce this on my end.

I’ll run some better tests there tonight, but I’m not sure about when that error happens in there since it had never happened to me there, only to my students…
I’m also unable to reproduce it whenever I please, it’s pretty rare… I actually see that bug comming in because I’m currently mostly developing some assets for my team t use via BP instead of the usual Visual Studio, So I begun working with print strings a lot… and on average I run UE4 on my PC about 8 hours a day, 6 - 7 days a week… and for the past few months I’m mainly working on Development through BP… so print string comes in hand 90% of that time… and yet, there were only about 10 - 20 times that happened… maybe 2 or 3 times on 4.6, the rest on 4.7

I’ll reply again after some tests at the school.

Hi Eyez,

Have you been able to test this at the school?

If I may interject, I can reproduce this in PIE by bringing up the gameplay debugging tool (’ (apostrophe key)), then stopping PIE (Esc) [i.e. quitting PIE with the tool on]. On subsequent PIE, log is not shown on screen. As mentioned, quitting the editor with logging in this state requires a couple of editor restarts to restore. Sometimes, bringing up and hiding the gameplay debugging tool restores printing as well.

Hi everyone,

Thank you jubanka for the information. I was able to finally reproduce this with the Gameplay Debug mode and have entered a bug report, UE-14330 to be assessed by the development staff. If you press ’ two times when you restart PIE it seems to reset the Debug mode and allow you to continue to see your print strings on screen. This is the only workaround I have currently available.

Hi! sorry for the delay!

I did run a lot of tests on the school but I couldn’t reproduce it enought by “random means” (I.E. asking the student to dabble with it, and trying various setups), untill… well, Untill I saw a student closing the window with the ’ menu open and right after that it lost the print to screen functionality.

As Jubanka also stated, and I did tried it a couple times, it seems pretty consistent now… but in all of the machines I could only get it to work while on english keyboards (but mainly because I can’t bring the console up with ABNT keyboard structure)

I am using 4.8 and experiencing the same bug. Actually, it’s two bugs it seems. First, sometimes debug output is not printed to screen, but it is printed to log/console. I haven’t found any reason to why this happens. Usually a editor restart or two fixes the problem. Also I cannot open the GDT at all, maybe because I am working with a German keybord, and we need to hit SHIFT+’ to get the apostrophe key. Any ideas?

Hi haimat,

This has been fixed internally and is slated for the 4.9 version of the engine.

Thanks for the reply! But which bug do you mean, access to GDT or PrintString?

The print string bug (UE-14330). Are German keyboards typically AZERTY? If so, there is a bug report already in for specific keybindings not working with AZERTY keyboards, specifically the ù, £, §, ^, _, ', or ². This bug has been backlogged but if this is the case I can increase the community interest, which while not a guarantee may help to bring more attention to the bug in question.