Blueprint multiplayer tutorial not working

Hi everyone!

I’ve been following the tutorial from Epic Games on how to make a multiplayer game, and so far I was able to have the Steam overlay, but I can’t find any online sessions when I have my project running on two different computers under two different Steam accounts.

I’m pretty sure that’s because how the blueprint has been setup, but I can’t find out the specific reason why. Furthermore, I’ve downloaded other projects that make use of the same functionality, and those work.

These are the tutorials I’m referring to:

Any help?

Cheers!

Hey braisbr1,

We cannot look through all the videos and hope to find a issue with them. You will need to give us some more information to investigate from.

Such as, explain what about your Blueprint setup is having a issue finding sessions. You can also post screen shots of your Blueprint as well as any logging messages that may pop up when the sessions are failing to be found.

Thanks.

You will definitely need to provide screenshots of the issue that is occurring and the blueprinting you currently have. Otherwise, there isn’t much that any of us can do.

Yes, sorry for this late reply, I was uploading the project into Dropbox in order to share the blueprints with everyone. Here’s the link:

I would love to post screenshots of the blueprints, but I don’t know where the error might be, since I created several (as per the tutorial). I’m attaching those I think might be critical, here they go:

What happens when you try to create / join a session?

When I create a session, let’s say on computer 1 (the host), I enter the lobby.

When I join a session, on a second computer under a different steam account, it says “Search failed. Please try again.”

Hey braisbr1,

Sadly, I do not have the time to go through your project. I can however forward you to a thread that has the complete setup for Steam, including a sample project you can download.

https://answers.unrealengine.com/questions/484873/413-steam-setup-not-working.html

Hi again Kyle,

and thanks for your reply. I did download your project yesterday, the one you attached on that post you linked me to, and it worked fine - I even reviewed the code you created and I can’t see the differences between yours and mine, even though the blueprints are somewhat different. Thanks for your time though, I’ll keep trying, and if you ever have time to look through the project and come up with something, you’d help me a ton.

Thanks again!

Did you ever get your project working? I’m running into similar issues after following the BP MP tutorials.

Hi Puglesh!

After the 4.15 build, the tutorial seemed to work. I downloaded the project they provided, and at least that worked. If you try to follow the tutorial step by step, you might run into some issues - so I wouldn’t do that. You might find yourself trying to learn from them only to be put of in some random video because the version you are using and the one they employed aren’t the same.

By all means you’ll learn a lot from those tutorials, but last time I checked there were several people encountering problems. My best advise is to download their project and modify the blueprints / assets they provide, and work from there.

Cheers!