BluePrint flow animation not always work

I just followed a tutorial by Zak here

The steps as in the video.

I dont always see the flow animation between nodes, it sometime appear to single blueprint instance and sometimes does not appear to any of them. The blueprint graph was successful to execute as expected but only the animation did not occur.

It is very cool to see animation like that, it help me to understand the work flow between the nodes in a very easy way.
Attached is the box I used

Make sure you select the appropriate Debug Filter. You will only see the flow for the blueprint you select here.


You mean the circles that are moving along the lines?

I did that but I see the lines between nodes change color to white and no animation.

No circles and no animation, the line path change color to white instantly I will try to attach my blueprint

Hi MorningStar,

Would you be able to attach a copy of your Blueprint and provide additional reproducible steps? What exactly do you do to get this to occur?



Unfortunately the project is no longer exists but the steps as in the tutorial. I press on play then walk into the objects, sometime I see the animation with only the first placed object and sometime none at all but the connected lines turn white instantly.

Does the animation of the wires occur when you overlap the pickup and then stops afterwards, is this what you are referring to? The animation of the wires only occurs when the event happens.

What happens if you create a Blueprint with just an Event Tick and Print String like below? Does it not animate?


The object is destroyed and particle appear as it should when I walk into it but no animation. I tried now this simple blueprint above and the animation occur normally. I will try to recreate the tutorial again and upload.

Ignore the problem about it occur only once I forgot that debug only work with specific selected object. I created the first part of the tutorial now and no animation. tell what I should attach and how as I still learning the engine.

This is before and after I walk into the pickup

From your Before and After images, when the object is in the world and you pick it up, does the blueprint animate at all? In the after image, it won’t animate again because it only animates when the Overlap Event is fired. Did you try hooking up the Event Tick like I mentioned before? This will always show animation for that node in the graph.

No animation at all, event tick attached with print string animate normally.

As Jerizo said in the initial response, double check that the debug filter is set (from your images above, it is hidden):

Sounds like it is working as intended that the wires fire off when you overlap the pickup but stop afterwards. If possible and you are still not getting the animation when picking up the item, maybe a video will help us see the issue as I am unable to reproduce it.

I had 4 pickups and even though the debug filter was in the pickup 3 when I walk into it I see no animation. do you know a free software for recording desktop video ?

Try Fraps… being able to see what’s occurring will help narrow down the issue. :slight_smile:

fraps did not capture the blueprint window so I used windows encoder and could not configure to capture full screen but the video
display that the line change into white without animation. If I had more time I would search for better software.

Appreciate your patience while I try to reproduce the issue. One more thing to try would be to post your pickup blueprint file so that I can load it up on my end and see what’s happening. Hard to tell from the video if the debug filter was on and if the box was successfully generating an overlap event.

Programmers should be patient. Tell me how to give you that file ?

Try going here:

C:\Users\USERNAME\Documents\Unreal Projects\PROJECTNAME\Content

Under Content, assuming you saved it in the Blueprints folder, it would be under there.

EDIT: It should be a .uasset file that you post.