Blueprint editor crash on startup after upgrade to 4.18

Hey, I am using unreal from source, and decided to upgrade the project to the latest version of engine. However, there is a corrupt blueprint in the project that prevents editor from starting (I am not sure if this is the only problem). In the version I used before, 4.16 it did not cause any troubles.

I have located the exact blueprint that was reported in the log, tried to remove it from the project and reload the editor, however that failed because things in the startup level depended on it.

I have changed the startup level, removed the blueprint, but editor crashes again. However this time without error log. I tried to run it outside visual studio, and it generates the following log:

[2017.12.23-21.54.02:812][  0]LogTexture: Display: Building textures: T_MacroVariation (AutoDXT, 2048X2048)
[2017.12.23-21.54.02:812][  0]LogWindows: Error: === Critical error: ===
[2017.12.23-21.54.02:812][  0]LogWindows: Error: 
[2017.12.23-21.54.02:812][  0]LogWindows: Error: Fatal error!
[2017.12.23-21.54.02:812][  0]LogWindows: Error: 
[2017.12.23-21.54.02:812][  0]LogWindows: Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION writing address 0x9c0c4b60
[2017.12.23-21.54.02:812][  0]LogWindows: Error: 
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x000000009755ACBA UE4Editor-Navmesh.dll!dtNavMesh::connectClusterLink() [c:\data\microsoft_uwp_unreal\engine\source\runtime\navmesh\private\detour\detournavmesh.cpp:1278]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x000000009755B0A9 UE4Editor-Navmesh.dll!dtNavMesh::connectExtLinks() [c:\data\microsoft_uwp_unreal\engine\source\runtime\navmesh\private\detour\detournavmesh.cpp:1021]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x0000000097558097 UE4Editor-Navmesh.dll!dtNavMesh::addTile() [c:\data\microsoft_uwp_unreal\engine\source\runtime\navmesh\private\detour\detournavmesh.cpp:1772]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x0000000077E5D315 UE4Editor-Engine.dll!FPImplRecastNavMesh::Serialize() [c:\data\microsoft_uwp_unreal\engine\source\runtime\engine\private\ai\navigation\pimplrecastnavmesh.cpp:414]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x0000000077E5ED4D UE4Editor-Engine.dll!ARecastNavMesh::SerializeRecastNavMesh() [c:\data\microsoft_uwp_unreal\engine\source\runtime\engine\private\ai\navigation\recastnavmesh.cpp:704]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x0000000077E5CAED UE4Editor-Engine.dll!ARecastNavMesh::Serialize() [c:\data\microsoft_uwp_unreal\engine\source\runtime\engine\private\ai\navigation\recastnavmesh.cpp:737]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x000000007C824F79 UE4Editor-CoreUObject.dll!FLinkerLoad::Preload() [c:\data\microsoft_uwp_unreal\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:3300]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x000000007C932BD9 UE4Editor-CoreUObject.dll!EndLoad() [c:\data\microsoft_uwp_unreal\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1554]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x000000007C94A93D UE4Editor-CoreUObject.dll!LoadPackageInternal() [c:\data\microsoft_uwp_unreal\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1333]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x000000007C949D7D UE4Editor-CoreUObject.dll!LoadPackage() [c:\data\microsoft_uwp_unreal\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1430]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x00000000768E8A94 UE4Editor-UnrealEd.dll!UEditorEngine::Map_Load() [c:\data\microsoft_uwp_unreal\engine\source\editor\unrealed\private\editorserver.cpp:2492]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x00000000768D9D25 UE4Editor-UnrealEd.dll!UEditorEngine::HandleMapCommand() [c:\data\microsoft_uwp_unreal\engine\source\editor\unrealed\private\editorserver.cpp:5968]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x00000000768BDDDD UE4Editor-UnrealEd.dll!UEditorEngine::Exec() [c:\data\microsoft_uwp_unreal\engine\source\editor\unrealed\private\editorserver.cpp:5445]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x00000000771A3519 UE4Editor-UnrealEd.dll!UUnrealEdEngine::Exec() [c:\data\microsoft_uwp_unreal\engine\source\editor\unrealed\private\unrealedsrv.cpp:672]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x0000000076BDD0EE UE4Editor-UnrealEd.dll!FEditorFileUtils::LoadMap() [c:\data\microsoft_uwp_unreal\engine\source\editor\unrealed\private\filehelpers.cpp:2229]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x0000000076BDCEEC UE4Editor-UnrealEd.dll!FEditorFileUtils::LoadDefaultMapAtStartup() [c:\data\microsoft_uwp_unreal\engine\source\editor\unrealed\private\filehelpers.cpp:3477]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x0000000077157767 UE4Editor-UnrealEd.dll!FUnrealEdMisc::OnInit() [c:\data\microsoft_uwp_unreal\engine\source\editor\unrealed\private\unrealedmisc.cpp:348]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x0000000077115A11 UE4Editor-UnrealEd.dll!EditorInit() [c:\data\microsoft_uwp_unreal\engine\source\editor\unrealed\private\unrealedglobals.cpp:97]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x00000000221E4831 UE4Editor.exe!GuardedMain() [c:\data\microsoft_uwp_unreal\engine\source\runtime\launch\private\launch.cpp:150]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x00000000221E49CA UE4Editor.exe!GuardedMainWrapper() [c:\data\microsoft_uwp_unreal\engine\source\runtime\launch\private\windows\launchwindows.cpp:134]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x00000000221F243E UE4Editor.exe!WinMain() [c:\data\microsoft_uwp_unreal\engine\source\runtime\launch\private\windows\launchwindows.cpp:210]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x00000000221F40BA UE4Editor.exe!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:283]
[2017.12.23-21.54.02:812][  0]LogWindows: Error: [Callstack] 0x00000000B2982774 KERNEL32.DLL!UnknownFunction []
[2017.12.23-21.54.02:813][  0]LogWindows: Error: [Callstack] 0x00000000B5170D51 ntdll.dll!UnknownFunction []
[2017.12.23-21.54.02:813][  0]LogWindows: Error: [Callstack] 0x00000000B5170D51 ntdll.dll!UnknownFunction []
[2017.12.23-21.54.02:813][  0]LogWindows: Error: 
[2017.12.23-21.54.02:831][  0]LogExit: Executing StaticShutdownAfterError

Here is the screenshot of the exception being thrown from the vs.

Hey, try deleting intermediate, binaries and saved folder. Regenerate visual studio project and try again.

Maybe try setting a default game mode and setting the startup map to something super simple without navmesh.

I tried. Same error.

So the engine starts now correct? If you re-add the nav mesh does it crash again?

You can’t do Createdefaultsubobject outside of construtor.

It’s weird that nav mesh is crashing that way. Are you using a new level?

I got rid of the nav mesh on some simple test scene level, got rid of the corrupted blueprint, got rid of the level that has been using it. Now I gotta figure out how to restore stuff I need without causing the crash again. Thanks a lot! :slight_smile:

I tried playing the level, but not it crashes “No object initializer found during construction” which is I believe caused because I recently moved “CreateDefaultSubobject(…)” out of constructor to post init components, since I had been triggering some breakpoint whenever starting the engine, and moving these and other initializing lines out of it seemed to get me rid of the error…however I am not sure, I am researching the crash now.

Fixed the problems. Now I managed to start the level correctly. However, I tried to add the nav mesh on the scene and as I tried to drag it it crashed with the same error in the original post.

Now I tried creating a completely new level, and have been able to add the navmesh without crashing.

After deleting an AI character (on old level) that uses the navmesh, I was able to add it again without crash also…but after removing it, and trying to add it again, it crashed one more time.

For some reason, I can drag the navmesh on the scene, but when I try to resize it, or drag it, or whatever interaction I make with it, that happens more than once, it crashes…this is the last line in the log before crash

[2017.12.24-16.53.43:042][296]LogEditorViewport: Clicking on Actor (LMB): NavMeshBoundsVolume (NavMeshBoundsVolume)

I have found this, will try now and report back after rebuilding.

Not working (there is obviously too much code to be modified #includes, and dependencies on the modified class). I will probably downgrade vs version, they said the problem will be fixed in 15.5.3 or in 5.6 preview 2 (no idea when does that get released).

If you are able to make it work on a new level there might something broken in your current level. Maybe taking things out at a time might help you figure out what is breaking.

I’m encountering this exact same problem with the provided ShooterGame example project. It seems like the compiler was optimizing away dozens of things it shouldn’t in the navmesh system. No idea why.

If you want to continue working on other things, I figured out I can compile the projects successfully using the Debug target because it disables compiler optimization.

This is not a long term solution, however.

edit: I should note I did a full reinstall of UE4 and redownloaded the project and got the exact same problem the exact same way. May be a visual studio error? I haven’t tried a different version of visual studio because I can’t afford to break my other workflows.