Blueprint Debugging - F10 Step Key Does not work


When debugging blueprints the “Step to the Next Node” using the F10 key does not work on OSX or Windows, using UE4 4.7.3.

Hey Markusvdr,

Thank you for letting us know that F10 doesn’t work when a breakpoint is added to the node. I have reproduced this issue in-house and verified that the issue was already entered into our system. If for any reason you need to reference this bug, please refer to: UE-9771

If you have any further questions, please do not hesitate to submit a new question to AnswerHub!

Cheers! :slight_smile:

how is that going, with ue-9771?

Hey CriErr,

Thanks for checking up on this bug, currently it’s still set as ‘to do’ and it’s ‘unresolved’. I do not currently have an ETA on when this will be resolved. Feel free to continue checking in periodically.

Have a great day!

how is that going, with ue-9771?

i’m wondering, is that gonna work as in shawshank redemption, so after few years of asking we gonna get basic functionality working or thats just wasting support time and not gonna get further?

This bug is still listed as a priority 3, therefore priority 2, 1 and 0 will be ranked above it and fixed first. It’s marked as ‘to do’ still. I see that it was last reviewed back in July. Hopefully this will be fixed in the near future however at this time, there is not an estimated time frame available.


So, its been 6 month from original post, how’s is our ue-9771 doing?)

UE-9771 is still a priority 3. It’s not resolved at this time.

“F10” Hotkey for “Step” in debugger still not working in 4.10.2.

It is really annoying not to have this feature, especially when the button in the toolbar switches places depending on the blueprint the debugger goes to (clicking blindly on the mouse key while concentrating on the event graph is no viable option).

Should be bumped up in priority, especially as that would seem such a minor task.

Any word on this for 4.11? It seems like a really important thing to have when debugging blueprints and not that complicated to fix. I know, I know, nothing is ever as easy as it seems, but his is a pretty useful tool that’s much more complicated to use than it needs to be due to the issue Hoaxx mentions. Would love to see this moved up in priority.

This is still unresolved and on our to do list. Thank you for checking up on this report!

Can we bump this up in priority? It makes stepping through blueprint code such a hassle that it’s pretty much useless to me except in very simple cases.

UE-9771 is set as a priority 3 (normal) bug and has been updated to include interest from the community, so the developers know you all want this to be fixed.

Thank you!

+1 having the issue as well, this is dreadful.

+1 here too! It’d be cool if there was somewhere to vote for bugs to be fixed :slight_smile:


Was this ever fixed?

You can track the status of this issue here:

Here we are 7-17-17, 845 days later. 581 Work Days. 4,648 work hours. Is this still a priority 3 bug? Can we assume now Priority 3 means, “Meh, not going to bother with it?”

Hey… Are you selecting the right instance to be debugged?

I find out that if you have a wrong instance selected, it will not stop in your breakpoint.
Make sure you specify the right instance, or at least don´t specify any if you don’t know or you want any…

Also, keep in mind that when you debug one instance, probably the instance selection will set to that instance automatically, and this could be a confusion because you believe that you have it in “Any”.