Blueprint Components Not Updating

The blueprint causing issues is an implementation of a C++ pawn-derived class. I recently re-worked the inherited components of the class and it seems to be causing strange issues when the actor is brought into the level.

In the blueprint editor, the components are correctly shown with their proper hierarchy. However, as soon as I drag that actor into the world, the components are all over the place and one is completely missing.

Here is the list of components shown correctly in the blueprint editor:


When dragged into the level, the actor’s components are set to this:


Notice the absence of “BeamLeftParticleComponent” and the “BeamRightParticleComponent” is incorrectly parented.

The editor crashes as soon as I hit play. I assume as a result of the missing component causing a nullptr. The crash log was taking ages to display for some reason.

I have tried hot reloading, restarting the editor as well as building in Visual Studio with the editor closed. I’m assuming something has been cached?

Hopefully this is the correct section. This issue seemed more blueprint-based than C++.

Please help! Thank you so much in advance!

So I realized that when I click on the missing component in the blueprint editor, the details panel was blank. Like it wasn’t getting initialized. So even the blueprint editor didn’t have a valid component.

I tried everything: recompiling, deleting code, rebuilding, deleting binaries/intermediate, regenerating VS files.

I figured “what the heck” and just created 2 brand new particle system components and attached them which worked perfectly. Exact same code with new variable/component names.

I am leaving this as a possible solution to save some future person a bad time but no way I’m marking this as answered.

Does anyone have any idea how to “force” a hard recompile? I thought deleting binaries/intermediate and generate visual studio files would be enough but it wasn’t.

This problem of the details panel being blank can be fixed by going to Class Settings, switching the Parent Class, and switching it back.