Download

Blocky Shadows on Modular Character

I’m a bit new to lighting and I’m trying to figure out a shadow issue on a modular character I am building. Here is the torso with material applied, as I zoom in closer to the shadows under the arm area they get blocky with clear lines separating the shadow across the mesh:

This was placed in a new blank project with the default lighting. I’m not sure whether I should be looking at my material settings or the lighting/shadow settings. Any leads here would be much appreciated!

It could be you don’t have smoothing applied to your mesh when you exported to UE4.

That was my first thought as well. I double-checked and re-exported from Blender trying both the smoothing (face) and smoothing (edge) settings. I still get this result, unfortunately.

check the import settings for unreal as well, make sure you are importing the models normals and tangents.

if you have a normal map applied, double check how you baked that (i.e. you may have baked the hard normals into the normal map)

Okay I tried re-importing, I did have “compute normals” checked before but I tried importing the normals and tangents this time and appear to be getting the same result:

I am setting up my normals using a master material and then adding the normal map to the instance. I noticed I see the same shadow issue whether I add my own normalmap or use the default set up here:

For reference I baked the normalmap in Blender baking from high-res (multi-res modifier 3) to low res

It’s definitely your mesh settings.

Go into the lighting section of the skeletal mesh and mess around with the checkboxes until you get acceptable results.

Keep in mind this is also in relation to the light source type in use, so the persona window shows you static.
The game/pie may be dynamic requiring different settings altogether.

Could also be contact shadows or a similar setting that’s screenspace based. Hard to tell from Screencaps.

You can check if it’s the smoothing group by looking over the wire frame view and comparing - but it doesn’t look like a simple smoothing issue.

Your character skin though.
You definitely want to output tangent manually deriving it from the normal map / making relevant changes to the mesh material slot settings.

Thanks for the reply!

So I did a simple rotate of the preview scene set in the skeletal mesh settings and the actual shadows look fine! Then I followed your step looking at the mesh grid and it does line up with what I was thinking were the “shadow striping” which should mean it’s a smoothing issue.

I went back and tried every smoothing option Blender has available and nothing seems to make a difference. I also tried right-clicking and “shade smooth” the mesh in Blender just to make sure I didn’t miss that for some reason. Also re-checked for vertex doubles (didn’t find any) since that has caused me issues in the past. Still trying things but no dice, so far.

Your character skin though.
You definitely want to output tangent manually deriving it from the normal map / making relevant changes to the mesh material slot settings.

I’m having a bit of trouble following this (sorry I’m still pretty new!) and I’m hoping you may be able to elaborate? I have a basic understanding of worldspace vs tangent normals and I’m not quite sure what you mean here (perhaps a screenshot example?)

Check this

Thanks again for sticking with me on this!

I reviewed that entire topic and tried every suggestion (outside of changing the code in GPUSkinCache.cpp, is that still a thing in 4.26.2?) and my mesh fails the first “roughness” test.

I’m not sure what else to try in Blender as I’ve run out of options to try in FBX export/import. I’ve checked the model thoroughly and there are no issues with it, at least while it’s in a 3D rendering program.

I noticed in the topic you linked the OP was dealing with this problem while working with Dual Quaternion Skinning Mode, which I as well am using. Is this related?

Edit* I just migrated my content to a blank UE5 project to test and the problem is gone. Interesting.

Maybe you have a modifier on with smooth?
Maybe vertex smoothing is on?

Have you gone into edit mode, selected the faces, and made them smooth via the menu option?

And in the export options, are you choosing faces as the smoothing option?

1). I’m not using any modifiers other than the Armature one.
2). Vertex smoothing is not an option that I know of in Blender? I have “shade smooth” set instead of “shade flat” if that’s what you’re referring to.
3). I went through selecting all of the faces and shading them smooth with the menu option - this doesn’t do anything for me since they’re already smooth. I did try Vertex > Smooth Vertices setting and this does attempt to round things out. It distorts my mesh quite a bit though but I tested an FBX export anyway and it did result in the same issue.
4). In the FBX export options, I always choose the “Face” smoothing setting although I have tried all of them numerous times in trying to solve this issue.

Is it something specific to UE4? Because it’s fine now in UE5.

If the same file is fine in ue5 then it’s just your import settings that are messe up.

It could be you aren’t importing with mikkt space or some other setting in that section is messed up.