Download

Blocky Shadows being emitted from my light fixture

I’m currently having trouble with shadow detail being emitted from a light fixture I downloaded. The shadows it casts on the wall are all demented and jaggered.
At the moment, this wall’s light mass res is 1024 (which is already high for a small wall), but look at all the jaggered edges! The only way I can eliminate this is if I bump up the res to 4092 - which is way way to much.

I re-modeled the light fixtures myself and sure enough, I got the same problem. Thing is, if I do a test and put a point light in front of a cube and cast a shadow on the same wall, there are no jaggered edges around that shadow. So I know it’s not the wall. And I’ve already tried increasing the res of the light fixture itself.
So why do the shadows emitted from my light fixtures become jaggered?

Your help – is my blessing.

Bumping thread for answer

Are those wall light static meshes set to static?
It could be a difference between baked lighting and realtime.

HTH

Do you mean the lights themselves or the meshes?
The lights are static. I don’t know about the meshes…

Bump… Again. Seriously, can i get some help here?

Are you building your lighting at production quality? The quality of your shadow edges is dependent on the lighting build quality.

Additionally, you could try raising the light’s radius. This will be both more accurate and give nicer shadow edges. Be careful not to intersect the barrier around the lights though, as that will lead to artifacts. Still, even setting the radius to a few cm can have a big impact on your shadows when you have something so close around the light source.

I mean the static meshes around the lights.