Blending Animations are turning character around!

Hello, my problem is that the animations I captured with my 3D cam are causing problems if I think the pelvis bone is rotated. I try to rotate the bone but this destroys the animation.

Everytime unreal engine blends between two animations (eg: blendspace) the character turns 360 degrees and changes position. Is there a way to fix that in 3dsmax or in some other program?

THANK YOU :slight_smile:

I have a related issue which I can’t find answers to online.

I’m importing animations from a 3dsmax biped, and when the animation attempts to blend between another animation, it appears that spine_03 (on the mannequin) is “taking the long way” to blend into the animation. In other words, instead of rotation just a tiny distance to return to the animation (think of a use where you’re blending between a punch and an idle or a running animation) the spine rotates in the complete wrong direction giving a really bizarre, exorcist effect where the character’s spine spins around in a the wrong direction.

I’ve managed to patch this up by making the blend duration EXTREMELY short (.01) , but this isn’t much of a fix because then I might as well not be using animation blending at all. The character then snaps between animations which is less than desired behavior.

It seems like it’s related to your problem though, I’m curious if you ever found a solution or cause of the problem. If anybody else can weigh in here, help would be greatly appreciated.

Did anyone find a solution to this? I’m having the exact same problem.

I had this same problem driving me nuts for the past 3 days, and this was the only post on the internet that showed proof that someone else had this issue. I just fixed it in my project! I had a cover animation blend space for facing left, an idle and a walking animation, while standing in cover, on a 1D blend space. The idle animation was facing the wrong direction by 180 degrees, so I rotated that idle animation in Blender and spat out the fixed FBX. After that was done, I ran into the issue described in this thread. I kept trying to fix it by further modifying the idle animation, but ultimately I fixed it by running the second animation, the walking animation that was already pointed in the proper direction, through Blender and rotating it by -360 degrees. I’m not sure if it was fixed by the -360 degree rotation or if running both animations through Blender made them compatible with each other when they weren’t before, but one of those two things definitely fixed it. You can see this reddit thread for more info.

I had the same issue. My animation was made facing opposite direction so I imported it using 180 degrees Z rotation and my character was turning 360 degrees when blending animations as well. So I had changed import setting to -180 degrees (minus instead of plus this time), reimported and it fixed rotation. If your animation facing correct direction try to import it using -360 degrees.

Check rotation of all roots. Blend rotates it in mindlessly.

I fixed blending by matching roots and manually fixed pelvis. Stupid solution though, I believe there should be something built-in. Like letting know blend to rotate clockwise idk.