Download

Blender Users - Help & Advice Needed

using 2.72a version of blender and still trying to get blender to work right.

I can get static meshes working alright or decently but skeletal meshes, mainly issues with the skeleton itself keep messing up, so…

*** Please Note: I’ve already looked at all the old videos & tutorials and probably almost all the old information available. Including most posts here on forums.***

I was wondering what version of blender you are using? (if you are doing so, successfully)

Looking for any workflows that actually ‘work’. (message if you need to)

Which export option or options that work for you (7.4 or 6.1 ascii) & are they working correctly?

*** Please include version & any variation in results in any response, as well, if you can.***

This has gone on so long, about to ditch Blender as far as UE4 goes. :confused:
I almost wonder if the contribution made to Blender to help get FBX exports working in UE4 was a waste of effort, what do you think?

(On a side note: as much as I like & admire Blender and have so for years, after dealing with it over time & it’s issues with exporting, especially to game engines.
I’ve often wondered if they receive contributions to ‘Not’ export properly or is it just the license restrictions, especially in the case of FBX files. (makes one wonder)
I mean Blender does so many things right, you would think a working export option would… well, work!)

  1. I use the version 2.7 :slight_smile: -> works perfectly
  2. When you use the 2.7 you dont need a special workflow, because normally it should work without any problems -> otherwise make sure that you always go to Object-Apply-Scale/Location,Rotation (in the tab beside the “Modes”) before you export it
  3. I just use the ordinary fbx exporter -> file - export - fbx

do you mean version 2.70 ?
and the 7.4 export not the 6.1 ascii version ?

I’m using 2.72, but I’ll gladly revert to an earlier version if it’ll work.

Yep, version 2.7 -> never had problems with that one. I dont know which export version I use, but it’s just the ordinary one (File-Export-FBX-leave everything like that) + I made one single modification, because I’m using root motion anims: Blender to UDK Player Model – Kris Redbeard (blender adds a root bone by default -> so you will have to edit some files) :smiley:

thx for replies btw, fighter

yeah, just checked to make sure i’d applied everything before export
( do you use a certain armature in your skeleton or do you think it matters?
I’ve been using the octahedral, because it’s what I always used, but I see there is stick, b-bone, envelope, and wire as well now)

atm, i’m trying to export a vehicle type of skeletal mesh which is an issue in itself sort of, I can use the UE4 pre-existing models w/o problems but not my own. :frowning:
(I used Make Human once to see how it worked, haven’t tried using it in blender then exporting yet, but straight from make human, everything seems to work & skeleton isn’t messed up.
this is another source of frustration, since whenever I export from blender things mess up)(will experiment more w/ Make Human later)

and I’ve seen that link before though, and will check it out and see if that helps some. (thx) I had read several times about blender adding an extra root bone for some reason. (for what, who knows) but again will look into that

It doesnt matter which armature you use -> I also use octahedral, but my 3d artist uses the stick -> I see no difference in the import/export process :wink:

How does your skeletal mesh looks like after you have exported it from blender?

I’m using Blender 2.72b.
The workflow i’m following for export in UE4 is the one on the Epic’e site ( somewhere ).
I have any problems exporting stuff in the engine but before of exporting my static meshes i set the scale in the exporter to 50.00.
The exporter I use is the 2.74 but even choosing the ascii 6.1 i haven’t issues.

Little off topic: I just have issues when i select edges,faces and vertices with this version of blender. No other issues.

I need to test it further as far as functionality, but it just looks shrunken.

Like all the bones are stuck at 0,0,0 origin and not scaled at all, still working on it tho’, just doesn’t look right.
the skeletal meshes I used before that looked that way, the wheels went nuts as compared to the UE vehicles that were setup the same way.

regular static meshes I usually don’t have many problems with, I leave scale alone and either (in the past) have used decimal setup w/ .01 in blender (scene display setup tab (right)) or just scale up the model using 1 meter as units, ue4 doesn’t seem to care which, but it hates for skeletons to be messed with at all, from what I’ve seen.

I think you mean this post: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine Forums :slight_smile: You just get problems when you try to export skeletal meshes -> everything works fine with static meshes

When it looks shrunken, make sure to use the right scale (Exporting a skeletal mesh from blender - Animation - Unreal Engine Forums) + do the stuff with the Object-Apply-Scale/Location,Rotation

But when you post a picture of how it looks like, we can probably better help you :smiley:

Exactly :smiley:

yeah, was thinking the same thing:
(picture’s worth a thousand words)

models import fine, but this is what my skeletons look like (they look like they are stuck at 0,0,0)(head & tail)(very small) :

a156c0456f8b0fbb2ea26ae4e3ecaacb32eab46a.jpeg

this is under my normal looking skeletal mesh, ie: got no issues with the mesh itself, well so far, lol

byakurei, thx for posting, have you had any success w/ skeletal mesh exports?
also what problems with selecting are you having? I admit I mainly use ‘b’ or box select then mostly ‘ctrl - L’ but got to admit selecting can be hard on complex meshes

continuing to look into this for now, hope it isn’t something stupid on my part

why don’t you both just make your models in blender the size you want them to be in UE4? it works for both static and skeletal meshes without having to scale up during export or changing the unit scale.

also the section on the wiki about scale has a lot of wrong and misleading information.

UE4 only shows the heads of bones (it doesn’t show the tail) witch is why they look small.

have you tried clearing scale/location/rotation on the armature then re-applying them?

***‘and no, but have made several attempts usually I go back to a normal mesh or a new model when testing’

thx for taking the time to reply, which version of Blender are you using?
and if anyone has a workflow I can compare with written down or whatever, they could share?

(such as for example: create mesh, check scaling &/or apply, add armature, set (some way ?? or not), add bone, move to (where needed), … parent bone to root (if needed), parent mesh to armature (which option) been using w/empty groups then setting the created vertex groups to mesh vertices, etc… (typed this quick, so… )

again, thanks, for now i’ll keep plugging away trying to work out a solution

@ smokey13 - after seeing that UE4 doesn’t show the tail of bones, I see that I can actually click in the general area and select bones, is that normal?? so at least I have something to go on and keep looking for my mistakes or improper workflow, etc. (this looks like it just applies to Blender skeletal exports)
will keep working on it to see if skeleton mesh is useable like this

but thx to all, getting input to questions and solutions, helps get one thinking and really helps :wink:

Another time, have you done the part with the Object-Apply-Scale? (I know that I have said it several times and that it is getting annoying :p) Because (one of my old threads):

that’s what I did with UDk the beta version of UE4 and the current version of UE4 and it worked in all.

when I say wrong and misleading information I mean just that. for example on the wiki you will see this

pretty much all of it is nonsense. the fact of the matter is that 1 default unit in blender is the same size a 1 unit in UE4 so as UE4 uses 1 unit as 1 CM you can just use 1 unit in blender as 1CM, so if you make something in blender 100 units tall and export with scale set to 1(the default settings) it will be still be 100 units tall in UE4, doing it that way works for both static and skeletal meshes without having to mess with the unit scale in blender or scale up during export witch is easier and less hassle.

basically the wiki has been written in such a way that it makes people reading it think they have to mess with the unit scale or scale during export because its more beneficial
when its not at all, its actually more beneficial (less confusing and less hassle (especially for beginners or people new to either program)) not to use the ways written on the wiki.

no, that skeleton doesn’t look normal;) but fighters link should help.

no problem:), at the moment I am using 2.72, I think its the latest official release.

my workflow is basically the same for static and skeletal meshes.

1: make mesh
2: unwrap UV
3: apply materials and make textures
4: apply smoothing groups, maybe the edge split modifier as well if needed.
5: apply scale, I model to scale anyway but just to make sure its correct.
at this point I would make collision meshes ect if it was a static mesh and then export.
6: add armature
7: with the armature selected switch to edit mode and scale/duplicate/extrude bones to make the skeleton.
8: parent all child bones to there parents and the all parents to the root bone.
9: apply scale to the armature, again just to make sure its good.
10: parent mesh to armature, I usually select the “empty groups” option and then use weight painting, I sometimes use the other methods depending on what the model is.
11: apply scale to armature and mesh, always do the armature first, you don’t really need to apply scale again but as it only takes 5 secs you might as well:p
12: create animations if needed.
13: export with default settings.
14: import with “use TOA’s ref pose” ticked and boom…done.

that’s just my basic workflow but it works every time without issue and the best part, no messing around with scale of units or during export.

hope that helps:)

thx again, and thanks for taking the time for these replies

@fighter5347 - lol at that last post at the bottom, I see this was a hard lesson that you learned well and will take your advice to heart. And altho I use it religiously I am going to check and do it more often, especially like in #9 that smokey13 pointed out, I think I just apply to both mesh & armature there, or could have, will try armature by itself first because the armature/skeleton looks like where my problem lies.

@smokey13 - I tried reverting back to 2.70 last night with no noticeable difference, so will probably go back or try the 2.72b latest release. thanks for that breakdown and taking the time to respond to all that, and thanks especially for that workflow breakdown, I will look close & compare it with what I’ve been doing. :wink:
I also had good results before when I did like you said and didn’t do the unit scaling, etc. and just used units as intended, always thought it was nonsense but was desperate to achieve the desired results, so will use that method. (just have to set the camera back a mile, woops kilometer, lol)
I haven’t looked at that split edge modifier too closely yet, but see a lot of people use it, have to check it out some time.

@both - I’ve noticed when working in UE4, Blender, or whatever software, a huge tendency to get so focused that ‘Tunnel Vision’ sets in and you just have to set back & start looking at the basics. And in this, it really helps to have others to relate their experiences to compare with. If not then it makes it hard to break out of the human tendency to never admit that one is or could be ‘wrong’ and we start looking for other things to blame. Hard lesson to learn and even harder to remember.

so again, a ‘Thank You’ is in order :wink:

I got a bad result from it. Here is my post about the issues:
https://answers.unrealengine.com/questions/146301/blender-impossible-to-get-animated-rig-working-ins.html

ok quick question.

how are you setting scale in blender? the easiest way is to just use 1 default blender unit as 1cm, scaling skeletal meshes during export usually gives bugs like your seeing.

–EDIT–

I just checked the advanced settings and they have changed “use TOA’s ref pose” to “use Time 0 Pose for Ref Pose”.

I will have a go at that. Here is another thing i discovered.
When you import an .fbx from unreal engine 4 into blender. first it looks to be normal scale.
Then when you actually move it around and press CTRL + Z twice.
It suddenly jumps into scale by 100.
Does blender automatically shrink it by a 100 when importing or something?

omfg yes i got it working!
gonna post a video about how i got it to work when i have time for it prolly around next week!
thank you guys in this thread for all the info! worked!
The only thing i was off about was the Ref 0 thing. was just one button and i messed with it for like a entire day trying all kinds of uploading differences etc XD haha
ok anyways heres result for those who want to see and feel the joy! :slight_smile:

Next step is getting the animations to work inside UE that i made :slight_smile: