Download

Blender / Unreal ugly shadow

Hi,

I’m currently trying to learn the basic concept of light in unreal. To do this, I made a little example with spartial rounded boxes (modeled with blender) but when I build light, the result have some ugly shadows.

I have tried to fix this problem by :

Nothing works, somebody know how to fix this please ?

Thanks

1 Like

Do you have a lightmap in UE? Take a look at UV channel 1, it should look ‘sane’…

Thanks for sharing this informative and amazing post here. I found it very interesting and enjoy reading this blog. Will wait for more posts.

@ClockworkOcean Since my first post, I have change the UV Map.
The UVMap in UE channel 1 looks like this:


And the result after calculating the light is:

I don’t think the UV Map generate is bad, but I have never done a UVMap before so I may be wrong :confused:

I will try make the round corner differently (adding quarter sphere instead of using bevel tools) to see if I see any differences.

I am wondering, does the number of island count in a UVMap ? Does this:
image
and this:


Will result be the same ?
I will try different things and post the results here :slight_smile:

@krhicranes20 Thanks for enjoying this post, hope it will helps you :slight_smile:

Thanks !

Okay so that is the result of my tests

First of all, I have tested 2 differents ways of unwrapping UV in blender with a basic square
Results below:



With only 1 island (2nd picture), unreal generates a stretched UVMap

Second, I tried to make the square with 1 round corner using a quarter of sphere:


(Remark: For this one I didn’t use the Smart UV Project of blender to generate the UV because of the bad UV result it gaves me)

And finally, I tried split the UV into several islands:


(Remark: For this one I didn’t use the Smart UV Project of blender to generate the UV because of the bad UV result it gave me)
The result is better but the shadows are still here :confused:

Do you have any idea to remove these shadows ? Are multiple island in UV really the best choice or is it one island and changing light settings ?

Thanks

To me, what I see is likely due to bad, or default normals, or tangets. So, first make sure you have good normals in Blender, and then make sure you export those normals/smoothing in the fbx. I usually use the edge option.

Thanks to help me. To my point of view, normals of the object are good:

I searched to visualize tangets and only found a way the colorize the object but I didn’t understand if it is good or not :confused:
image

I tried to export the model as you suggested but no change

Thanks

Hi!

Wherever there is a cut on your lightmap, there is a chance to get an error in lighting! So try to keep as many faces together as possible!!
Also angular islands won’t be calculated in high accuracy unless you pixel/grid snap every outter vertex on the lightmap uv!
My approach would be to leave the separations where they will be less visible… if these cube-y thingies will sit on the floor: cut the bottom rectangle as a separate island, leave the rest together and pull the rest of the 5 sidedes flat! /I don’t know what the skinning option in your 3d app/ …also pixel/grid snapping would help!

1 Like

Oh and higher lightmap resolutions also help + adjusted Lightmass settings…

@Makigirl I tried your solution and it results are much better than all of my other tests !


Thanks a lot ! :smiley: