Blender to UE4 - Static Mesh Scalling doesnt work anymore

Hi,

I had defined several Blender fbx export Presets for Staticmeshes, since 4.11 or 4.12 they don’t work correctly anymore. The mesh is always too small, changing the UE4 import settings to x100 or even x100000 doesn’t have any effect. Previously the Blender export options, and the UE4 Import Options worked fine.
But now I can’t get any of my meshes to actually visually appear in UE4 unless i check "!Experimental! Apply Transform, and even if I do that, i still have to scale the mesh x10 and the rotations are messed up.

For whatever weird reason Skeletal Meshes still import correctly with my Export Presets.

Blender version 2.77

Hi AlexW88,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to reproduce this on my end?
  • Is this limited to one asset or is it any blender created asset?
  • Does this occur with any other 3D modelling software?

Hey Adam,

It appeared in different projects, some were rather clean.
I saw it happeneing with every asset I used recently, however I just created a Cube and exported it as is, it imported, small, but it imported so there might be some specific step in the modelling process that breaks the model scale I have yet to discover.

I can only test with Blender. I will test some more and ping back when I have more Info. If you feel like experimenting on your own I can also send you one of the broken meshes.

If you could send me one of the asset’s this has occurred on I’ll be happy to take a look.

That’s nice, maybe you can make some sense from it link text

I tested the mesh sent and everything seems to act as I’d expect. Checking the blend file I noticed that you are not using metric units for scale. Try switching the units to see if you get desired results. I found that, upon import with the current fbx, setting the universal scale to 10 scales the mesh to a size equivalent to a picket fence for a third person character.

Thank you Adam for testing! I loaded the mesh now in several Projects and it appears that there silently has been a new option for fbx imports: “Transform Vertex to Absolut” If that is toogled the mesh will scale as expected, else it will be infinite small.

To clarify, using “Transform Vertex to Absolute” resolved the error you were seeing on your end?

Yes, If I check that Box “Transform Vertex to Absolute” it works as it used to be in older versions of the Engine. If it’s not checked the mesh will be infinite small. By infinite I really mean infinite. I’m not sure if this is expected or not, but using that option resolves the problem for me.

Hi AlexW88,

I did some digging and have discovered that this is expected behavior in most cases. The “Transform Vertex to Absolute” used to be a hard-coded feature. It was exposed in 4.12 for some specific instances, but for the vast majority of cases should simply be left checked. Leaving it on should prevent this behavior from occurring in the future.

Hey Adam, any details on the use cases? I’m doing some stuff with rendering depth data from kinect and need really high poly meshes, and want to make them as lean as possible. I couldn’t find any details in the 4.12 release notes about this setting.

Hey muchcharles,

Looking at the OP’s files, his scale seems to be way off in the Blend file. If you swap his scale to centimeters and then 0 out the transforms, you can see his issue, which is essentially why disabling “Transform Vertex to Absolute” was causing so much trouble. With it disabled, the editor disregards the objects transformations within the scene and takes the object’s base transforms (Zero’d out for Translate/Rotate and 1 for scale).

This shouldn’t have any affect on how high or low poly your meshes are though. Could you expand on your concerns?

-Matt W.

PS - Check this out

Btw. there’s a Ticket for this issue: Unreal Engine Issues and Bug Tracker (UE-37790)