Download

Blender Export Axis Settings ignored?!

I have a fresh Blender 2.77a install on my computer and I want to export a simple mesh to fbx. Problem is, it always appears in UE4 rotated on its head by 180°. So I think “ha, easy thing, I just change the axis in the export settings and it will be rotated just like it appears in Blender” but no matter what axis I set, the **** thing is always on its head! As if the axis settings when I export do absolutely nothing. Searching through Google didn’t bring a solution so I’m a little helpless.

It’s probably easy to fix but I feel stupid that I can’t get it to work. What am I missing?!
Thank you so much!

Screenshots of the original model and import settings would be good to help. have you applied roatation/scale etc. in Blender before exporting?

Sure thing!
The model is a very basic test model that I did not rotate. Export scale works fine, so I don’t think it has something to do with it. I’ve added all the settings so you can see for yourself. And before you ask: changing “selected objects” to true does not make any difference - seen that suggestion in other threads already. The Pivot is also on top of the mesh in UE4, which is another indication that it just rotates the model and ignores the axis settings I’m using when exporting.
7c20613497f530734f998803983e1a47e52b8cf4.jpeg

I can put whatever export axis settings I want: Z up, -X up, Y up it doesn’t matter the model in UE4 always looks like its seen here on the screenshot.

Screenshot 2016-07-04 15.18.03.png

I guess it might be to do with your pivot being rotated 180˚ around the X axis, your Blue line should be pointing up.

Have you tried this this button turned on? it attempts to apply the transforms.

Screenshot 2016-07-04 15.20.01.png