Blender animation becomes small

Hm, sounds like a exporting bug. Try using Blender Version 2.70. Newer version gave me bugs like this.

Hi, Every time I import an fbxlink text skeleton mesh with an animation I get a good looking mesh with correct dimentions, but when I start the animation the objects becomes tiny (100 times smaller) but with the correct animation
attached an easy example of the fbx what am I doing wrong in Blender or UE4??

This is related to this:

If you scale your armature and mesh by 100 (applying translation/rotation/scale after that) and then export as “scale = 1” in the fbx exporter it should work.

The scale option in the exporter seems to work only for the mesh.

I had the same issue. The Models exports ok, but as soon as you play an animation, the model gets tiny. Though the animation is playing.

I changed from 2.72 to 2.70 and the bug was gone.

Hi everyone,

I just tested this on my end and everything seems to be working as intended. How are you performing the scaling? If you do it through the world settings in blender before exporting (set world settings to metric at a scale of .01) it seems to come in without a problem.


I saw here that you attempted using the 6.1 exporter as opposed to 7.4, did this have any impact on your bug here?

Hi ,

It seems that the 6.1 exporter was only a help to avoid the twisted bone problem. The scale problem is even worst with the 6.1, as problems with bone sizes start to happen. Currently it only works if the export scale is 1.0; FBX 7.4 binary exporter is more correct in this matter, only the size change when playing the animation.

If you need a file to test, you can download the model of the twisted bone thread here:


Sorry, I forgot to answer your previous question and mention that the scale is performed when exporting.

File->Export->FBX : Scale : 100 (export parameter on the left of the window)

I will need to think about using world setting to handle the x100 scale and always export as 1.0 scaled. It could be an option.

Edited: using world settings for me is not working and Unreal complains about different bone transformations than the original.

Have you tried rolling back to blender 2.7 instead of using 2.73 if you are using the latest version? There have been several users reporting issues with 2.73, but 2.7 seems to export/import without the same errors.

Yes, I’m using the latest version (2.73). I’m using features that appeared on 2.72 and I’m waiting for the final version of the custom normal editing (2.74, maybe?). So downgrading is not an option.

I have found workarounds for all my error situations. Although the workflow is not smooth (and sometimes forget to do the things in the special way that avoids the failure, making me to repeat the operation), now at least there is a way.

I will wait to see if future improvements/bug fixes in the exporter (blender) or the importer (Unreal) make this process easier. If I found a stopper situation in the future I will let you know. And if the current problems persist in the future… I will try to help looking at the exporter(blender)/importer(unreal) code.

Good luck with the bug hunting!

1 Like

Can you possibly go into detail on how you made it work? This answer currently isn’t very helpful.

Hi MJLaukala,

A workaround for this is:

  • Scale your armature and mesh by 100 in blender. So, 100 Blender Units = 1 Unreal Unit.
  • Apply translation/rotation/scale, so mesh and armature are at (0,0,0) with scale (1, 1, 1).
  • Export to FBX using “scale = 1” in the exporter option.

This should work.


Verify if you are using the metric system, i had the same problem and changing from metric system to None solved it.


When I try to apply scale to the armature my animation goes crazy. What can I do? Thanks.

Hi dacanizares,

If your animation only contains rotation/scale keyframes it should be working ok. But if your animation contains translation keyframes, you are right, the animantion could be completely broken and you will need correct them.

That’s why I think this should be corrected in the Unreal importer. This just served me as a workarround for some simple animations or as a way to “port” my already done animations to a new scale and continue animating to that scale.

I still don’t have enough time for this… but downloading UE4 git source code for now…

Ok. first post here. hope to be glorious :slight_smile:

So. my workaround was:

change grid size in blender to 100 ( hotkey N → display → gridfloor → scale)


the exported the mesh and armature without any sort of animation

and imported in UE4 as a skeletal mesh, but without the “import animation” selected

Now, back to blender and create your animation. When exporting just use the same method but deselect the mesh and export only the armature


finally, go to ue4 and import the animation and select the armature from the first export


The only workaround I’ve had for this issue is to recreate my armature once the scale of my mesh is correct for UE4. If I an existing armature, this scale issue appears when animation is selected in UE4 (even if I apply transforms after scaling).

Name your armature something besides “armature” and animations will come in same-scale in UE4.

This issue is very old but posting anyway in case anyone new has this problem and wonders why.


Thank you, I was just having this problem. It’s bizarre that this bug is still around after 2 years.

Thank you so much !!