Download

Blender and UE4

Hello!

I’ve been trying to import some of the static meshes (.FBX) I’ve made in Blender into UE4, but I have had serious issues with it. A thread a few days ago was made about this, but didn’t really provide a solution to my problems. From what I gather, my Static Mesh doesn’t have the right UV maps/channels. Whenever I try and build lighting with one of my Static Meshes in it, either the lighting around it looks really weird and is just blotchy black marks or it gives me an error saying my UV maps are overlapping. Anyone have a Blender specific solution to this problem? Any help would be greatly appreciated. Thanks!

It works the same it did in UDK, if you have problems, i suggest you update the FBX file you exported from blender with the Autodesk FBX converter, that will make the FBX file more modern and surely work better.

I have tried that, and always use the Converter, but the issues still persist.

you need to have 2 UV’s, the first is used to displays your texture/materials and can have overlapping UV islands, the second UV is for the lightmap and can not have any overlapping UV islands.

Geodav has a video on his youtube channel that shows how to create the second UV if your not sure how to do it.

hope that helps:)

It helped, but now it says they are overlapping by 2.9%. Any ideas why?

Click Ctrl+A and after that Ctrl+P in the uv window -> now you shouldnt get that error anymore

What does that do? And I’ve been using the Smart Unwrap function. Does that make a difference?

I always use the smart uv project to create my 2nd uv channel.

Ctrl+A -> resizes everything
Crtl+P -> move all parts so that they arent overlapping

Ok last question, and sorry if I’m being really noobish. When I Unwrap it, nothing appears in my UV window in blender. Do you know why? Thanks!

watch my blender to udk videos, the work flow is the same for ue4 just make sure the scale is larger

I’ve been looking at your videos and they are very helpful, however my problem is that nothing appears in the UV window so I cant utilize Fighters suggestion to make sure they don’t overlap

When you’re creating the uv map for the lightmap, you should use the lightmap pack function

that function sucks for creating lighmaps for unreal

Yeah I’ve tried it and it just ends up creating the worst lighting you’ll ever see

Yes, but you can also use the smart uv project

Could you probably upload the file somewhere so that we can take a look at it -> because normally you just have to go into the edit mode - then click onto smart uv project - and then they should appear in the uv window

whilst the “smart UV” option does work for a quick lightmap the best workflow I found to get a perfect lightmap is to mark seams and use the standard “unwrap” option, then just rearrange the islands a little.

Would marking the seams on advanced meshes take a really long time?

not really, the longest its taken me is around 30 mins but that was a very complex mesh, the average mesh takes me 5-10 mins.

http://i.imgur.com/q7WLDQO.jpg and http://i.imgur.com/UhEBogV.jpg are what happens when I use the smart UV mapping. I looked at the seams created by the smart mapping and they correspond with the blotchy spots. Any idea of how to fix this?