Blender 2.76 Socket Scale Issues

So I thought I had read throughout the forums that Blender’s scale issues on FBX export had been pretty much solved by now (since 2.75 onward). Indeed, from my testing it seems to work perfectly for static mesh imports and skeletal mesh imports. I’ve been using Blender’s scene settings as Metric and Scale: 1.0. By exporting scale 1.0 and importing scale 1.0 the meshes import into UE4 as the correct size (that is, 1cm in Blender = 1cm in UE4). The problem is that when I add a socket to my skeletal mesh inside Persona, the socket is huge! (I think it’s 100 times too big).

The scale of the socket is correct if I create a new Blender asset using a scene scale of 0.01, but unfortunately changing the scale of an existing asset doesn’t work, it seems I have to start from scratch with a scale of 0.01 so I may have to redo all my skeletal mesh assets that I’ve created. So is it going to continue to be the official recommendation to keep Blender’s scene scale at 0.01, and is this desired behavior? Or is it a bug, since a scene scale of 1.0 works fine for mesh sizes but only seems to mess up the socket scale?

Also I’m not sure if it should be a separate thread, but the rotation widget inside Persona doesn’t work properly, it might be related to issues of scale as well.

The other critical step after setting scale to metric, degrees, and 0.01 is to Apply the Rotation and Scale. It’s under the object menu, or Ctrl+A. Select all armatures and meshes, then Ctrl+A > “Rotation & Scale”. If you don’t “Apply”, then bones and other things will rotate 100x slower than they should, or be off by a scale of 100, like your issue.

This is one of the major issues with the Blender pipeline right now, and the other for me is that it adds the Armature as your root bone in the FBX, so you have to animate armature, and not the root bone if you want root-motion.

That’s a good point about making sure to Apply Scale before exporting. I’m just worried that if I make all my assets using a scene scale of 0.01, they will then “fix” it so 1.0 is required and it’s going to mess up everything all over again

Thanks for the tip. I’m pretty new at this so I’m learning as I go!

Well if it makes you feel better, I’ve been using UE4 for over a year and they haven’t fixed it. Even after making a generous donation to the Blender foundation.

And from what I read on Blender forums, about people exporting FBX for Unity too, many Blender developers are afraid of Autodesk’s lawyers when it comes to updating the FBX code.

Also, a side note: In the “N” menu in the 3D viewport, I noticed that if I set my View > Clipping from 1mm to 100m (default 10m) and Display > Scale to 0.01 that working in Blender is a bit easier at the adjusted scale.