Download

Black sun and light shaft artifacts when Physical Light is too bright

Hello,

I’m using UE4.21.1 and I’m experiencing with Physical Lights some weird black artifacts. I think they are related with some kind of overflow since they’re only appearing on GTX 9XX cards and not on 10XX cards, so maybe the quantity of the graphic card RAM is involved.

Here two screenshots that show the issue:

https://i.imgur.com/hFsRNmm.jpg

This is taken from a PC with a GTX 970 card (4096 MB memory)

https://i.imgur.com/bIcZwgE.jpg

This is taken from a PC with a GTX 1060 card (6144 MB memory)

Some details about the light:

  • Extend default luminance range in Auto-Exposure settings is ON
  • The light source is set to 125000 lux
  • The emissive skylight material is set to 70000
  • Of course, both screenshots use the same build data

The “Apply Pre-exposure before writing to the scene color” fixes the issue but it breaks scene capture render targets.

Any workaround/suggestions to this?