Black screen on app startup


I’m trying to install an android app on my phone, originally tried one of the sample demo levels with a top-down blueprint and C++ with no avail. So I am resorting to trying to install the Flappy Chicken from the marketplace, assuming everything that would need to work should work since it was made by Epic. I can deploy the app to my phone and install it, but when I go to open the app, it flashes a black screen then closes. Am I missing something? In the editor I go to “File > Package Product > Android”. Then I copy over the .bat, .apk, and .obb to my android phone (Galaxy Note 2) and run the .apk to install the app. No errors or suspicion of warnings anywhere in this process.

I’ve had the same experience attempting to deploy to a first-gen Nexus 7 (an aging piece of hardware now).

Android deployment is still a bit rough. Right now the devices with the best support are the Galaxy S4 and the Nexus 5, and I expect support for other high-end devices won’t be far behind. I’d expect support for slightly older or mid-range devices will be added eventually (as much as hardware capability allows), but newer devices are likely the priority.

There’s your problem. The BAT file is a Windows batch file, which you run from your PC to install the APK and OBB. If you open up the batch file in Notepad, you can see the ADB commands it runs to install everything.

Also, make sure you’re using the right compression for your device.

:frowning: Also having this blackscreen of death problem… Cant even get Tappy Chicken to run :frowning:

I am using a Asus Fonetab 7 (2013) with Intel Atom Z2560 for Android Dev.
It runs Epic´s Citadel Unreal 3 tech demo on highest settings without any problem so I just cant understand what I am doing wrong! :frowning:

Haha, that makes sense. I was copying over because I couldn’t get unreal to recognize my phone so I thought I could just copy over the files just the same. Finally got the recognition and works like a charm!

Still not working all I get is black screen :frowning:

Same for me.

Black screen on Side scroller example.
Tappy chicken runs fine.

Epic Citadel from Play Store running smoothly.

My specs:
HANNSpad - SN10T1
Processor: ARM Cortex A9 (Dual Core)
Chipset: nVidia Tegra II T20 1Ghz
Memory: DDRII 667 Mhz, 512 MB
OS: Android 4.0 ( Ice Cream Sandwich ) - Custom ROM

**bump **bump

Same problem with my Note 2 (GT-N7100)

Try disable Mobile HDR, it has helped me with rendering issues on galaxy note 3. In the editor go to Edit->Project Settings->Rendering. Untick “Mobile HDR” and remember to click “Set as Default” or it wont apply. Fingers crossed that works for you.

Thank’s Xenogenik, I tried that also, but, I never clicked “Set as Default”, now it’s working great thank’s. :slight_smile: I’m using Nexus 10.

Cant get any example to run on my Asus Fonepad 7 :frowning: with UE4 but with other engines including the UE3 Tech demo everything works 100% att full throttle…
This is very frustrating!! Tested with Sony Xperia Z and also with a Sony Xperia M and they work like a charm O.o …

This did the trick for me, now the SideScroller template is starting.
However, the scene does not seem to be illuminated. I can see the blue character and the moving sky.
Everything else is completely black.

I was able to resolve the not-illuminated issue.
The issue was caused by the wrong texture compression setting.

See this thread.