Black Screen on and GPU restart errors on iOS 9.0.1

Any default template projects without modifications, deployed to the device, can’t show anything on after the splash screen. Device log from Xcode 7 shows that iOS restarts the GPU every time I start any Unreal Engine apps compiled in UE 4.9.1. It seems that it only happens on the Metal renderer.

I have also noticed that triggering orientation change during (exactly during, not after) the GPU restart allows me to get back to the game (everything works, all visuals are back). In any other case it’s just a black screen.

on iOS 9.0.1, Mac OS Yosemite 10.10.5, Xcode 7.0, Unreal 4.9.1

[Xcode Device Log][1]

60183-xcode_device_log.txt (24.5 KB)

Backported my project to Unreal 4.8. No problems on 4.8 on iOS 9.0.1.

No luck with UE 4.9.

Hey Rachmiroff,

I have tested this with 4.9.2 and have not been able to get this to reproduce. Could you please attempt this in 4.9.2?

Thank you!

Everything works on 4.9.2. Thank you for the update.

I’m using 4.9.2 from guthub release branch, after my game start, screen is black, but i hear music and can touch UMG menus, but nothing is rendering.

Github release branch, ios 9.0.2, , Metal rendering, xcode 7.0.1

Packing game as Shipping version, for AppStore release

Hey ,

Please upload your from your iOS device. You can do that by attempting the following:


  • Open iPhonePackager (Engine/DotNET/IOS)
  • Select a uproject file (Optional)
  • Select the Advance Tools tab
  • Select Other Deployment Tools…
  • Select Backup Documents…
  • Select the IPA for the game you wish to get a log for
  • The documents directory data will then be copied to Engine/DotNET/IOS/IOS_Backups or GameDir/IOS_Backups if a uproject was selected
  • The log can then be found at IOS_Backups/Game/Saved/


  • Open Xcode (Install Xcode if you have not already)
  • Open Window|Devices
  • Select the device you want to get the log off of
  • Select the app you want to get the log from
  • Select the gear icon under the app list
  • Select Download Container
  • Select a location for the container file
  • Navigate to the file via Finder
  • Right click and select Show Package Contents
  • Navigate to the location of the log (AppData/Documents/Game/Saved//)

If you are able to, please also upload your project and provide it to me as a zipped file. If you wish to keep it private, please send it to me through a private message on the forums.

Thank you!

Test with TappyChikken, same error - black screen
[link text][1]

62100-tappychicken.log (16 KB)

I can play, and hear sounds. I’ts happen after i’m update to ios 9.0.2, same build working for ios 8

If i’m make build on windows (UE4 From Louncher) all is fine, but if in Mac Os (UE4 Builded from sources) - black screen.

Hey ,

Thank you for providing us with this information. I have looked into this further and spoken with the developers. They’re aware of the issue and haven’t been able to come to a resolution as of yet. The report for this issue is UE-21013. Please feel free to check into this in a few weeks.

Thank you!

I’m having the same problem. Nothing is being rendered on the , but it works fine on the 5c and other non-metal devices. The device log shows the GPU is crashing and being restarted:

[link text][1]

62659-iphone+5s+gpu+crash.txt (16.1 KB)

Recompiled the project on 4.9.2. The problem is back. The same errors, the same error log. Even the Tappy Chicken from the AppStore doesn’t work on the device. Any other games on other engines work fine.

Trying to build 4.10 github branch, but problem with black screen is still exist, i’m afraid it not be fixed for 4.10 release ;(

Same problem. :frowning: ( iphone5s , 4.9.2 full source)
rendering is not work. only black screen.
but I can touch UMG button. and iphone5, iphone6 is work(same source)


Could you please include the from your device? Also attempt this on Unreal Engine 4.10 Preview and let me know what happens. If you’re not sure how to get the off of the device, please review this [documentation][1].


A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums

[link text][1]
setting : iphone5s , 4.10 preview2

[2015.10.29-04.14.53:240][ 2]LogTemp:Warning: AddInventory: Action
is my game play log. When I touch the button to see the log.

64626-dc_iphone5s.log (24 KB)

Try to build latest 4.10 branch - black screen.

Log from device console [link text][1]

Looking at Trying restart GPU …
Maybe driver is crashed or something

64644-consoleoutput.log (98.8 KB)

I’m looking now for 4.10 branch on github.

looks like don’t solve black screen problem, just drop Metal support for iPhone5S, iPadAir2, iPadMini2 on iOS9, and iPhone 6 on iOS8(but in current branch stage for all devices on iOS 8).

Can we get some information about this decision?

This issue was fixed in 2749536 and it was verified. However, the iPad Air was left out and that’s being corrected currently. UE-21013 has been reopened and we’re hoping to have it verified soon.


Hi ,

I tested this under 4.9.2 on , running iOS 9.1 and Xcode 7.1:

1: When running a blueprint project everything works, no problems. You get the splash screen, a brief black screen, followed by the scene.

2: When running a code project, even a simplest one possible, the process stops after the brief black screen. The scene never shows up.

I then tried running the code project thru Xcode… It kept getting stuck giving errors related to “Internationalization” !!!